Questions about saving w/external HDDs

Discussion in 'OS X Mavericks (10.9)' started by linds15, Feb 3, 2014.

  1. linds15 macrumors 6502a

    Joined:
    Oct 16, 2012
    Location:
    Great White North
    #1
    i've noticed this since being on mavericks, its may have been like this before but im not positive.

    basically, if i save any file, in any program, when the dropdown save menu appears, it instantly freezes and waits for any external hard drives connected to load before i can save the file. 99% of the time im saving the file to my internal SSD, and the file is always opened from the SSD. is there a way to make osx stop loading any externals that are sleeping to save a document?

    hope i was clear with the issue
     
  2. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #2
    Yeah, I've noticed this happening more too. I'm not sure if it's a Mavericks change or I'm just noticing it more now.

    The "solution" to this is to go into the preferences' 'Energy Saver' section and un-check "Put hard disks to sleep when possible."

    That's not great because now you're running all of these drives all of the time, which is why I put "solution" in quotes.

    If you do end up doing that I strongly suggest lowering your computer's sleep time to something short so that at least they're not all running when you step away from your desk.

    That said, I don't like that idea and have simply just been putting up with the annoyance of waiting for them to load. (I do wish Mavericks was smarter about when it loads them up. Like, wait for me to click on the drive first!)

    So, full disclosure, even though this is an idea to try, it's not one that I do.
     
  3. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #3
    I've resorted to unmounting the externals when I am not using them, just to avoid this problem.

    A.
     
  4. linds15 thread starter macrumors 6502a

    Joined:
    Oct 16, 2012
    Location:
    Great White North
    #4
    thanks for the suggestions. id rather them go to sleep, like yourself, and deal with the holdup occasionally, than have them running.

    i also can't unmount them because the media that family member may be streaming is on there.

    glad to know its not just me though
     

Share This Page