Questions about Spirit

Discussion in 'iPhone' started by Vazzyb, May 4, 2010.

  1. Vazzyb macrumors member

    Vazzyb

    Joined:
    Mar 18, 2009
    Location:
    Cambridge, UK.
    #1
    Two questions !

    1. Is there an unlock for the the new boot rom 3.1.3 or 3.1.2 for the iPhone 3GS? ie. can you use blacksn0w on top of Spirit?

    2. Do I have to backup my SHSH files before I use spirit? If so, why?

    Thanks

    Vb
     
  2. Vazzyb thread starter macrumors member

    Vazzyb

    Joined:
    Mar 18, 2009
    Location:
    Cambridge, UK.
    #3
    Someone said you can use blacksn0w on 3.1.2 with new boot rom? Were they misinformed?

    If I want to downgrade back to something, wont I need my SHSH files backed up - i really need someone to explain this!
     
  3. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #4
    ^^^^
    they were misinformed.

    Yes. See thelatinist's thread on backing up SHSH.
     
  4. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #5
    Also

    you can not downgrade your Baseband even via shsh. No choice but to wait. Dev-team hints at one after 4.0 is released.
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    You need alot more reading and research before you get into it...
     
  6. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #7
    If your phone is a new bootrom 3GS but has never been upgraded to 3.1.3, I see no reason why you shouldn't be able to unlock with blacksn0w after jailbreaking with Spirit. The important thing is your baseband version. Check your Modem Firmware version in Settings > General > About. If it is 05.11.07, you can unlock with blackra1n; if it is 05.12.01, you cannot.
     
  7. Vazzyb thread starter macrumors member

    Vazzyb

    Joined:
    Mar 18, 2009
    Location:
    Cambridge, UK.
    #8

    Yeah this is exactly what I was wondering...whether or not your jailbreak had to be via blackra1n for blacksn0w to function properly...because it was certainly pitched as an unlock for NBR 3GS 3.1.2,

    Thanks very much to everyone for your help :)
     
  8. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #9
    No, blackra1n is not a prerequisite for blacksn0w. There is a Cydia package of blacksn0w which can be installed on any jailbroken device with 05.11.07. I've unlocked with blacksn0w after jailbreaking with PwnageTool.
     

Share This Page