Questions on Mail

Discussion in 'Mac Basics and Help' started by novetan, Oct 3, 2010.

  1. novetan macrumors 6502

    Joined:
    Sep 3, 2010
    #1
    Questions on mail

    1) How to have "bold" and "underline" in Mail. Has it got to do with 'Rich Text"?
    Its always blank off. Sorry, I'm not tech savvy.

    2) There is no spell check in Mail. Is that correct because I can't see in the customize tool.

    Thanks
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    You didn't say what version of the MacOS you are using (and therefore what version of Apple Mail), but they're mostly similar.

    1) Yes, to do any formatting your message needs to be "rich text"--the alternative is plain text, which is just what it sounds like: basic text, no formatting. When you are typing a message, at the bottom of the "Format" menu there should be an option that will say either "Make Plain Text" or "Make Rich Text"--if it says the former, it's already rich text and you should be able to add bold or underlined text in the message. If is says the latter, select that item and you will be able to format the text.

    You can set the default for new messages in the Preferences, under the "Composing" tab.

    2) Edit menu --> "Spelling And Grammar" --> Check Spelling --> While Typing. "While Typing" should have a check mark next to it, in which case Mail will underline misspelled words as you type (right-click or command-click on misspelled words to get suggestions of correct spelling). If it does not have a check mark, select it and it will from then on.

    Or, if you prefer, you can select "Before Sending" to do just that. You can also select "Check Document Now" to bring up the spelling panel; command-semicolon (;) will do the same thing.
     
  3. novetan thread starter macrumors 6502

    Joined:
    Sep 3, 2010
    #3
    Thanks so much for help. I'm expecting some kind of "B" and "_" Icon that I can set in the tool bar menu. Ok, I can use the Command key.

    Under Format, after I have checked "Bold" and "underline" and typed what is needed and thereafter I want to type plain, I can only unchecked "Bold" but just cannot uncheck "underline". All the following words will be continued underlined. If I were to switch to plain, all previous bold and underline will become plain.

    What has gone wrong?

    I'm using OS version 10.6.4
     
  4. dhd macrumors member

    dhd

    Joined:
    Dec 12, 2007
    Location:
    Hamster-Dam
    #4
    Hi there,

    When you are writing a new email, hit Command + T, the font window will open, from there you can have strikethrough, bold, oblique, etc.

    Greetz,
     
  5. novetan thread starter macrumors 6502

    Joined:
    Sep 3, 2010
    #5
    Thanks, and I learned a new command. But that still didn't address my issue in post 3
     
  6. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #6
    Interesting. I just tested this, and the behavior is exactly as you describe--if you turn on both bold and underline via the menu, type a bit, and then try to turn them off to continue typing in plain, you can't turn off underline via the menu or keyboard shortcut.

    Unless I'm totally missing something, this is clearly a bug. I see it under 10.5.8, so it's apparently been there for a while--I'm guessing so few people use the menus to set style that it's gone unreported.

    I just send a bug report (there's a "feedback" item under the Mail menu), but here are a few easy workarounds:

    1) In my testing, so long as you turn on bold and underline via the keyboard shortcuts (command-B and command-U), they can be turned off normally via the keyboard as well.

    2) Keep typing underlined text for a bit, then select the text you DON'T want to be underlined and hit command-U (the Format menu should also work); this will de-underline the text and you can then continue typing.

    3) After you're done typing, go back and select the words/phrases/sentences you want to be bold/underlined/whatever and use the Format menu or keyboard shortcuts to apply styles after the fact. I think this is probably faster than doing it on the fly, so long as you remember what you want bold/underlined.
     
  7. novetan thread starter macrumors 6502

    Joined:
    Sep 3, 2010
    #7
    Thanks for reporting and at least another one able to testified.
    I'm adopting method (3) meanwhile.
     
  8. she-la-la macrumors newbie

    Joined:
    Dec 19, 2010
    #8
    spell check in mail

    Hi I am having trouble with spell check in my mail programme with words like 'don't , won't haven't, words like this. If i type dont (without the apostrophe) it will not correct it, wont is another word which will not correct.
    Anybody else have this problem? and how do I correct it please?
     
  9. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #9
    This isn't really related to the original problem, but anyway:

    I'm assuming you're using Snow Leopard 10.6; I don't think 10.5 does autocorrect as you type, though it will mark misspellings.

    Under the Edit menu, go to Spelling and Grammar, and see if there's a checkmark beside "Correct Spelling Automatically". If there isn't, select it and a checkmark will appear, turning on auto-correct. If there's already a checkmark there, I don't know what's wrong, but you might try turning it off and back on again, or rebooting the computer, if that doesn't help.
     

Share This Page