Queston About DNS and Login Loop

Discussion in 'macOS' started by Reg88, Jun 24, 2012.

  1. Reg88 macrumors regular

    Joined:
    Jun 8, 2010
    #1
    Hi,
    I'm a newbie on OS X and I logged into a site that I normally login to often and when I clicked the "login" button, the URL bar in safari was flashing URLs back and forth -- as if it were stuck in a loop. I do think this instance was a simple brief error with the website in question, because I tried to login again and all was fine.

    I had navigated to the site via a google.com search (it's a very popular site) and I'm wondering :

    1) how do I tell if it's some kind of DNS redirect malware or just a simple screw up temporarily by the website itself?

    I see no indications of any DNS issues (e.g. when I type in a web address I always go to the correct site I expect to go to -- there is no redirection to some strange place I did not intend). And whenever possible I always click the padlock at the top right to verify that I am where I expect I am supposed to be on SSL sites.

    2) Is there a way in Safari to check on a non-ssl site to see if the site you think you are on "is the site you think you are on"?

    Also at this point I just wanted to take the opportunity understand:

    3) What to look for if I DID have some kind of DNS redirect trojan (though I am totally up to date with system update and I run clamXAV scans every day)

    4) Is there a website I can go to to check to make sure my DNS settings are going to the right place and that I'm not being redirected?

    Thanks for all of your help!
     
  2. Reg88 thread starter macrumors regular

    Joined:
    Jun 8, 2010
    #2
    Update:
    As an experiment I did it again to reproduce the problem:

    1) I went to google and googled the site.
    2) I clicked on the log-in page from the google listing (e.g the listings under the site on Google)
    3) I was then taken to the website and I then clicked the padlock in the top right on safari (and all was legit for the site).
    4) I then put in the credentials and hit login and got stuck in some kind of loop in the browser where it wanted to go back to google and kept flashing the URL back and forth with no progress.

    Does this sound like the website is having an issue, or my Mac?

    Thanks.
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    That sounds more like an issue with the website. Does this happen on any other site?
     
  4. Reg88 thread starter macrumors regular

    Joined:
    Jun 8, 2010
    #4
    Not that I've seen so far. And I tested it on a PC of mine and the same thing happens. Naturally that PC has a firewall and AV installed. But if you were to navigate to the site directly, then login is ok.

    Can you tell me what the signs and symptoms would be of a DNS-type redirect virus/malware on a Mac?

    If when I click on the SSL lock in safari and the certificate matches where I think I am, does that mean things are fine?

    Thanks!
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    A malware redirect would be like what you are seeing, but the site certificate would not match like you are finding. You are fine. I have not read about malware active right now on Macs that would do this.

    It sounds like the site is not handling redirects from Google properly.
     
  6. Reg88 thread starter macrumors regular

    Joined:
    Jun 8, 2010
  7. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #7

Share This Page