Quick FF2/3 troubleshoot help

Discussion in 'Web Design and Development' started by hobbbz, Nov 4, 2009.

  1. hobbbz macrumors 6502a

    hobbbz

    Joined:
    Mar 8, 2005
    #1
    Hello all,

    I've been updating my portfolio site at http://juliankussman.com .
    It's Flash and uses swfobject for embedding.
    I can't for the life of me figure out why it won't render in Firefox 2/3 on Windows XP.
    To make matters worse I don't have an easy way to test on that OS so I've been relying on Adobe's BrowserLab and reports from friends.

    I'm sick of it not working and I know someone out there might spot the problem in an instant.

    It works fine in FF on Mac, IE7/8 have some issues but for now I couldn't care less. I just want it to work in FF on Win and Mac so I can start sending out the link.

    Any thoughts?

    Thanks in advance.

    (also I just realized I originally posted this in Design and not WebDev so hopefully the mods won't strike me down for reposting)
     
  2. SrWebDeveloper macrumors 68000

    SrWebDeveloper

    Joined:
    Dec 7, 2007
    Location:
    Alexandria, VA, USA
    #2
    I can confirm it does not load properly on FF3.5 on XP.

    You're using v2.1 and they're up to 2.2 (latest stable) now.

    So first go to this project page to download the latest version, then install and change your code and see if that resolves the issue. Even if it doesn't, you always want to run the latest stable before looking for other causes.

    On a side note, it's much more reliable/faster to download it and load directly from your server than link it from Google's Ajax Libraries site.

    Report back after upgrading. That's my advice.

    -jim
     
  3. hobbbz thread starter macrumors 6502a

    hobbbz

    Joined:
    Mar 8, 2005
    #3
    I've reverted back to my server's local copy of swfobject and it's 2.2

    The reason I had it wired the previous way was because of some discussion on the swfobject google group.

    But it's all up to date and still not working now.
     
  4. SrWebDeveloper macrumors 68000

    SrWebDeveloper

    Joined:
    Dec 7, 2007
    Location:
    Alexandria, VA, USA
    #4
    Okay, if no changes I personally do not know why its not working and defer to others. Nothing seems to obviously stand out as wrong syntaxically.

    All I can say is I'd probably load the Flash conventionally, i.e. not using swfobject - instead using native HTML i.e. that which was generated by Flash when you saved to web. Normally swfobject is used because developers want certain HTML elements in their page to interact with Flash, i.e. a flash MP3 player but an audio play/stop button embedded elsewhere on the page. Of course swfobject.js merely extends Javascript thus anyone with Javascript disabled won't see your flash anyway. So why even bother using that method simply to load a fully flash page?

    If it's because of browser check conditionals (which I recall seeing) you can process that server side - no reliance on JS of any kind, and a far superior approach if your webhost has PHP or whatever. Otherwise, consider my question RHETORICAL - you're the developer, you do what's best for your site limited by your webhost capabilities. It's just a suggestion pending an obvious fix I might have missed.

    -jim
     

Share This Page