Quick Look behaviour changed

Discussion in 'OS X Mavericks (10.9)' started by VespR, Oct 24, 2013.

  1. VespR macrumors regular

    Joined:
    Jun 16, 2004
    #1
    In all previous OS X's, let's say you selected a bunch of images and then pressed space bar to open quick look. If you made it full screen, the images were full screen. Using the arrow keys to cycle left and right, images remained full screen.

    Now when you CMD+A and go into quick look full screen. The images are at their native resolution. You have to press option (ALT) to toggle the image going into full screen. If you cycle to another image, it'll need toggling to full screen, if you go back to the previous full screen image. It's back to its native resolution.

    Anyway know how to change this behaviour so the default is always full screen. Seems pointless going into full screen if the images won't do that by default.

    Thanks
     
  2. Baff macrumors newbie

    Joined:
    Jan 3, 2008
    #2
    I'm having the same problem. I had the same or similar thing happen when I updated to 10.8. I found a solution for it somewhere, but I don't remember where and after a couple hours searching the net it hasn't popped up :(

    I tried deleting the Quick Look pref files in the user library, but that had no effect.
     
  3. Simon Liquid macrumors regular

    Joined:
    Jul 4, 2001
    Location:
    Iowa
    #3
    I think I'm seeing the same thing. The first picture comes up zoomed in to fill the screen. When you go to the next picture, it's at its native resolution. Go back to the first pic, and you find that's at native resolution as well.

    PS - Kudos to Apple for giving the feature a name that is practically ungoogleable. There are probably 10000 results for Quick Look Mavericks/10.9. This is post is the only indication I've found anyone even has the same problem as me.
     
  4. Bruno09, Oct 25, 2013
    Last edited: Oct 25, 2013

    Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #4
    I don't have the problem and do not see any change in Quicklook behaviour (just tested right now both in ML and Mav).

    On Mavericks, press Alt to see the picture 100% size, then press Ctrl or Cmd to reverse.
     
  5. Baff macrumors newbie

    Joined:
    Jan 3, 2008
    #5
    Bruno, select multiple photos and open them in quick look. Hit Alt so it fills the screen. Hit right arrow to go to the next photo in the folder. In previous versions it would fill the screen, now in Mav it goes back to native size, so now we have to hit Alt for every single photo. Is this different for you?

    To make matters worse, the Alt key on my computer seems to be a little too sensitive so sometimes when I hit it, the photo zooms in and then goes right back to native.
     
  6. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #6
  7. Baff macrumors newbie

    Joined:
    Jan 3, 2008
    #7
    From that article: "As you flip from one file to the next, the Quick Look window changes dimensions to accommodate the size and shape of each. If you find this as distracting as I do, resize the Quick Look window a bit. Once you do, it stays there, and changes the size of the contents to fit."

    The last sentence is no longer true. That is the problem.
     
  8. VespR thread starter macrumors regular

    Joined:
    Jun 16, 2004
    #8
    Glad I'm not the only one finding this annoying :)

    I imagine there is a terminal sudo command to change the defaults behaviour to always preview items full screen.
     
  9. grumo macrumors newbie

    Joined:
    Aug 31, 2006
    #9
    Yeah, here's another +1 for searching for a solution...
     
  10. Porsupah macrumors member

    Porsupah

    Joined:
    Oct 18, 2013
    Location:
    Probably near London or San Francisco
    #10
    Same issue here. So far, I've had no luck finding any way of reverting Quick Look to its pre-Mavericks full screen behavior - for now, I'm just using GraphicConverter's slideshow function instead.
     
  11. davadam macrumors newbie

    Joined:
    Oct 29, 2013
    #11
    And another +1. The link Bruno posted does give a clue to what changed, though:

    To avoid the distortion that results in either case, press Option to make the image shrink to its true size. ​


    So maybe our friends in Cupertino reversed the behavior, so it would always show images at the "correct pixel size"?
     
  12. Simon Liquid macrumors regular

    Joined:
    Jul 4, 2001
    Location:
    Iowa
    #12
    I doubt it. When you go full screen the first item is zoomed, but if you skip ahead and go back it's not. Also, When you first select items, often the second and sometimes third item will be zoomed as well.

    It's buggy behavior either way and quicklook is more useful as a zoomed instant slide show than getting an exact audit of picture dimensions.
     
  13. AlligatorJack macrumors newbie

    Joined:
    Jun 14, 2010
    #13
    Quickfix window resize bug, please fix!

    Hey, I also want to request a bugfix from Apple here:

    The quickview window size can not be changed any more (only switch on/off full screen).
     
  14. Dualie11 macrumors newbie

    Joined:
    Feb 7, 2013
    #14
    An awkward work around for this is to use zoom on the middle button of your mouse. When you zoom the screen the picture in Quicklook will also zoom to fill the window. Then you can zoom the screen out. Still have to do it for every image though. Weird bug.
     
  15. Simon Liquid macrumors regular

    Joined:
    Jul 4, 2001
    Location:
    Iowa
    #15
    Another thing you can do is hold down the option button on your keyboard. Or put something small and heavy on it.
     
  16. Dualie11 macrumors newbie

    Joined:
    Feb 7, 2013
    #16
    Or just select all the images you want to browse, open in Preview, press command-shift-F, and then use the arrow keys to navigate through the images, or space bar to start/stop the slide show. Gifs won't auto-play though.
     
  17. rymulock macrumors newbie

    Joined:
    May 21, 2014
    #17
    Making slideshow images fullscreen

    This is what I have found works to display slideshow images always at full screen.

    Cmd-A to select the slides to display.
    Engage QuickLook with Shift-Option-Space.
    Click the upper righthand corner to go full screen.
    Press the Right Arrow to proceed to next slide(s).
    Keep proceeding to the next slide until you come to a slide that is not full screen.
    Press Esc on that slide. QuickLook recedes from full screen.
    Click the "+" button in the upper lefthand corner.
    Again click the fullscreen button in the upper righthand corner.

    All slides will now play fullscreen.
     
  18. xzytd macrumors newbie

    Joined:
    Jun 14, 2014
  19. fraserm75 macrumors newbie

    Joined:
    Jun 20, 2014
    #19
    Solution - not elegant

    Hi,

    I have same issue - upgrade straight from Snow Leopard to Mavericks 10.9.3
    The easiest way i found is:
    1- Select images
    2- Push spacebar
    3- Resize window handle (even slightly)
    4- Click the arrows at top right of window to bring quick-look to full screen.

    Now images are full screen.
    It is not very good behaviour- I prefer the old way- it's all full screen- I don't care if distorted a little- just want to be able to see it.

    If anyone finds an easier way please post.
     
  20. negsrus, Jul 10, 2014
    Last edited: Jul 10, 2014

    negsrus macrumors newbie

    Joined:
    Apr 16, 2012
    #20
    That's an understatement. IT'S BRAIN DEAD!! Ok, fine, I can understand how some want to see the images in the native resolution, but have the option to TOGGLE full screen for EVERY image. It's stupid that you have to hold down option. Or pick another button to toggle. JUST HAVE IT TOGGLE! For the love of, God. It's so stupid it's beyond belief.
     
  21. LozM macrumors newbie

    Joined:
    Aug 9, 2014
    #21
    I seriously just signed up solely to say I could hug you. An odd workout is better than nothing and this bugged feature has been killing me since it's inception.
     
  22. orsob macrumors newbie

    Joined:
    Sep 8, 2014
    #22
    Thanks rymulock.
    Apple has been alerted about this problem by me and others months ago, but they never bothered to answer (at least, I never got any replies).
    Every now and then Apple comes up with annoying things like this (does anyone remember when they changed the order of commands in the menus?). A little consideration for people who actually use their machines to work and not only as hubs for iphones and ipads would be appreciated.
     
  23. Hammido macrumors newbie

    Hammido

    Joined:
    Oct 5, 2014
    Location:
    Stockholm, Sweden
    #23
    What about Yosemite then?

    Hi… I HATE this problem and I don't think this clever workaround works on here =(

    Any new ideas or workarounds?
     
  24. subblue macrumors newbie

    Joined:
    Nov 8, 2014
    #24
    Another work around

    I find that if you enter full screen from a selection of images either by pressing alt+cmd+y or alt+space the first image will scale to fill the screen if it's smaller.
    However, for all other images just press and hold the alt key to keep them scaled up to full screen too :)
     
  25. Hammido macrumors newbie

    Hammido

    Joined:
    Oct 5, 2014
    Location:
    Stockholm, Sweden
    #25
    Hahah, but I've been doing like that for ages. I'd like to keep my finger OFF the Option key, because… You know.
    Anyways, I hope a solution through the terminal will be revealed ASAP!
     

Share This Page