Quick ques. iphone 2g, 3.1.2

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ssdsvanhelsing, Apr 22, 2011.

  1. ssdsvanhelsing macrumors newbie

    Joined:
    Oct 10, 2008
    #1
    hi, so i have an old iphone 2g, i never upgraded because i never needed to.
    however it seems that a lot of the new apps that are available require a higher operating system than my 3.1.2.

    now, ques. 1: is there 4.0, 4.1, etc. available for my iphone 2g?

    ques 2: if they are not available, is there another way to install apps that require 4.1, 4.2 on an older 3.1.2, by ssh or something like that?

    i really need the newer apps but i have an older operating sys. so please some advice will be good.
    thanks
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    No, the highest you can go with a 2G is 3.1.3
    You cant install apps that require 4.0+
    Even if you could trick the appstore to allow you to install them they wont open or run cause the dependency of the firmware is not there to support them.
     
  3. oakie macrumors 6502

    oakie

    Joined:
    Oct 16, 2008
    Location:
    seattle
    #3
    1. no.

    2. no.

    advice? get a new iphone.
     

Share This Page