Quicken 2007 to be 10.9 Compatible

Discussion in 'OS X Mavericks (10.9)' started by Pndrgnsvc, Oct 10, 2013.

  1. Gochugogi macrumors regular

    Gochugogi

    Joined:
    Oct 27, 2013
    Location:
    Sandwich Isles
    #2
    Indeed, Quicken 2007 runs fine under both Mavericks and Yosemite!
     

Share This Page