Quicksilver powers on but no chime, no video, no boot

Discussion in 'PowerPC Macs' started by sonicbuddha, Dec 25, 2006.

  1. sonicbuddha macrumors newbie

    Dec 25, 2006
    I had my quicksilver g4 for a few years before it conked out on me, leaving me high and dry. It would power on and stay on, drives spin up, fan spins, red light on logic board lights, everything as if it was going to boot, but I wouldn't get a chime or video and the front power light would power on but immediately turn off. It just runs and runs but never starts.

    So I switched out the logic board, thinking that was the problem. No, same results. I switched out the memory and video cards. Nada. I even tried running it without ram, just to test, and it gave me the expected beep code, clarifying its still doing a hardware test at the very least. I've tried resetting the PMU and even removed the battery for a short period, with no new results.

    Before I toss the whole thing, can anyone give me a lead? I'd love to keep this machine.
  2. SmurfBoxMasta macrumors 65816


    Nov 24, 2005
    I'm only really here at night.
    Without the chime (which is actually the "power-on-self-test" or POST indicator), or video, and the front power light going off, I believe you have a bad PSU, or maybe the front circuit board is dying.......

Share This Page