QuickTime 7 crashes on pressing 'Export'?!

Discussion in 'macOS' started by ericksgotmac, Sep 16, 2009.

  1. ericksgotmac macrumors regular

    Joined:
    Nov 22, 2008
    #1
    When I upgraded to Snow Leopard I thought that Quicktime X was supposed to be better. -.- ...NOT the case! I usually obtain .mkv movies with DTS or AC3 audio which I can't play since I don't have a receiver right now. So I have this system set up:

    1. MKMerger- Remove Subtitles and alternate audio.
    2. Quicktime 7- Export to .mp4 with passthrough video and convert audio
    3. VisualHUB- Process it into .mp4 with passthrough video and audio
    4. MetaX- Tag the movie with cover art and other metadata

    But since I upgraded to Snow Leopard, Quicktime 7 has been shutting down as soon as I press Export? Which puts a huge dent in everything since that was the only way for me to go from 1080p .mkv w/DTS(AC3) to 1080p .mp4 with stereo.

    Can anyone help me with this?
     
  2. Tex-Twil macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #2
    Hi,
    I'm sorry I don't know.

    But I think you should change the title of your post because "huge problem" is not so relevant. I think you'll get more answers if you the title is more specific.

    Tex ;)
     
  3. zerostar macrumors regular

    Joined:
    Apr 28, 2008
    Location:
    South Florida
    #3
    Why are you doing step 2 and not just going to VisualHub? What are you ultimately doing with this video in the end? Apple TV?
     
  4. darkpaw macrumors 6502

    darkpaw

    Joined:
    Sep 13, 2007
    Location:
    London, England
    #4
    Use Handbrake to convert the video. Works every time for me. However, I had to download and compile the latest source, rather than using 0.9.3 which is the already-compiled version on the website.

    Instructions to compile it yourself are here. It's really not that difficult.
     
  5. ericksgotmac thread starter macrumors regular

    Joined:
    Nov 22, 2008
    #5
    I tried going through VisualHub alone but the results are horrible. The picture is all pixelated and the movie becomes unwatchable. By running it through Quicktime 7 first and converting the .mkv to .mp4 it works fine but then I can't tag it with MetaX. I found out if I use Quicktime 7 and then VisualHUB with just passthrough on video and audio so it only takes about 5 mins, it stays the same quality AND I can tag it in MetaX without any problems at all.
     
  6. ericksgotmac thread starter macrumors regular

    Joined:
    Nov 22, 2008
    #6
    I don't need to convert the video, that would take hours and is pointless. I just need to convert the audio and then have it all packaged nicely in a .mp4 format WITH the original 1080p video.
     
  7. darkpaw macrumors 6502

    darkpaw

    Joined:
    Sep 13, 2007
    Location:
    London, England
    #7
    I had some issues with QT7 on 10.6. The 10.6.1 update fixed them. Do you have 10.6.1?

    As an aside, one of the annoyances I have with QT7 on Snow Leopard is that I can only do one export at a time. I could do multiple exports on Leopard, but this is a step backward on SL.
     
  8. ericksgotmac thread starter macrumors regular

    Joined:
    Nov 22, 2008
    #8
    I do have SL 10.6.1 and its not working at all. Should I try a fresh install with selecting QT7 instead of installing it after?
     
  9. darkpaw macrumors 6502

    darkpaw

    Joined:
    Sep 13, 2007
    Location:
    London, England
    #9
    Is there anything in your Console.app that might shed some light on why QT7 is crashing?
     
  10. ericksgotmac thread starter macrumors regular

    Joined:
    Nov 22, 2008
    #10
    All it says is...

    -[NSProcessInfo enableSuddenTermination] has been invoked more times than necessary to balance invocations of -[NSProcessInfo disableSuddenTermination]. Ignoring.

    I have no idea what thats means :confused:
     

Share This Page