Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

Jrtesq

macrumors member
Original poster
Aug 12, 2012
32
9
[cross-posted at Apple support community]

One of the non-admin users is having trouble with Quicktime (I think). Just started yesterday.

When we click on a video to play it, the following message pops up:

"Mac OS X needs to repair your Library to run applications. Type an administrator's name and password to allow this."


Then there are two fields below the message for me to type the name and password.

When I do this, nothing seems to happen. The error message goes away, but there is no indication that the "Library" is being repaired. If I try to open a video again, I get the same error message. I even tried waiting a couple of hours and then rebooting, but I still get the error message.

If I try to open Quicktime directly from the launchpad, I get the same error message.

This only happens with one user. The other two are not affected.

It seems that every other application runs fine. Just can't open Quicktime.

Any suggestions?


Running a 2012 Mac Mini with Mountain Lion 10.8.3
 

Jrtesq

macrumors member
Original poster
Aug 12, 2012
32
9
Thanks for the quick reply. I was wondering about permissions, but I didn't want to mess with them until I got some feedback from the forum.

I'll try repairing permissions when I get home from work tonight.
 
Comment

benwiggy

macrumors 68020
Jun 15, 2012
2,189
15
I've never heard of OS X announcing that it is going to repair itself somehow before, and if it wasn't for other info you gave, then I would have thought it was an exploit in the video. (The fact that you still get the message just opening the QT app, and only for one user.)

However, if it only happens in one user account, then you know where the problem lies: that user's Library folder. Might be worth deleting everything to do with QuickTime in there.

For the record, Repair Permissions does nothing for any files in the user domain.
 
Comment

Jrtesq

macrumors member
Original poster
Aug 12, 2012
32
9
Thanks for jumping in here.

I've never heard of OS X announcing that it is going to repair itself somehow before, and if it wasn't for other info you gave, then I would have thought it was an exploit in the video. (The fact that you still get the message just opening the QT app, and only for one user.)

Seemed strange to me as well. see image below

However, if it only happens in one user account, then you know where the problem lies: that user's Library folder. Might be worth deleting everything to do with QuickTime in there.

That was my initial inclination -- delete the stuff in the user's QT library folder. Is that a hidden folder?

Again, I didn't want to go trashing files without knowing what would happen.


For the record, Repair Permissions does nothing for any files in the user domain.

Thanks. I see this advice in countless unrelated threads. That's why I waited to do that. I wasn't sure if it would do anything positive, so I didn't want to chance something negative happening instead.
 

Attachments

  • IMG_3230.jpg
    IMG_3230.jpg
    570.9 KB · Views: 592
Comment

benwiggy

macrumors 68020
Jun 15, 2012
2,189
15
That was my initial inclination -- delete the stuff in the user's QT library folder. Is that a hidden folder?
Again, I didn't want to go trashing files without knowing what would happen.
The user's Library folder is hidden by default. You can access it by holding down <alt> and selecting it from the Go menu in the Finder.
There will be lots of files relating to QuickTime -- some in the Preferences folder (com.apple.quicktime.plist, and similar); Caches. There is no "QuickTime" folder as such.

But delete away with impunity -- you can always restore from your backup, can't you?
 
Comment

Jrtesq

macrumors member
Original poster
Aug 12, 2012
32
9
But delete away with impunity -- you can always restore from your backup, can't you?

True. That's why I keep 3 backups. Two physical and one with CrashPlan. I never want to be one of the folks who has to answer your question with "I haven't had a chance to backup yet," or "I was just about to back everything up when this happened." :D
 
Comment

Jrtesq

macrumors member
Original poster
Aug 12, 2012
32
9
There will be lots of files relating to QuickTime -- some in the Preferences folder (com.apple.quicktime.plist, and similar); Caches. There is no "QuickTime" folder as such.

But delete away with impunity

This worked. I just deleted all files in the Library with quicktime in the name. Logged off; logged in. Opened QuickTime. Success.

Thank you very much for the help. I'm grateful
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.