Quicktime Framework help

Discussion in 'MacBook' started by Pat13, Mar 2, 2013.

  1. Pat13, Mar 2, 2013
    Last edited by a moderator: Mar 2, 2013

    Pat13 macrumors newbie

    Joined:
    Mar 2, 2013
    #1
    In an attempt to fix problems with QuickTime based applications on my Mac book, I tried to replace my existing frameworks folder (as in user/system/library/frameworks) with a backup from a previously functional version of my computer. I now realize, after restarting my computer and perpetually hanging on startup, that this folder is integral in the startup processes of my computer. Is there any way to reinstall this frameworks folder because my computer is stuck in infinite startup, being held up by missing frameworks folders. I can boot into single user or verbose but commands don't work as the loading hangs there as well. I can't even boot from a startup disc. Can anybody help with this as I feel terrible knowing that I could have simply reinstalled the stock osx rather than tamper with frameworks folders and ultimately, my fate. Any help is appreciated. (This is a copy of the post previously posted on power pc forum-mobile site doesn't differentiate.)
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
  3. Pat13 thread starter macrumors newbie

    Joined:
    Mar 2, 2013
    #3
    I want to reinstall, but the system does not load enough to allow me to reinstall.
     
  4. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #4
    1. Are you saying it won't boot from your OS X Installer DVD?
    If you can't boot up from a completely separate install disk, then there's something wrong with your hardware.
    If that's not what you're saying, then reinstall the OS from the DVD.

    2. Swapping frameworks is an extremely bad idea, as you've found out. What was the problem you were having that led you to this as a solution?
    Is it possible the original problem and the current situation are related?
     
  5. Pat13 thread starter macrumors newbie

    Joined:
    Mar 2, 2013
    #5
    I can hold option down on boot and select the startup disc, but it never loads. The original issue was that multiple programs (namely pro tools and at a point premier pro) that used QuickTime to work routinely quit during or right after startup, citing missing framework files- an issue that began after recently downgrading from 10.7 to 10.6. So instead of reinstalling from the startup disc I tried to shortcut and ended up here.
     
  6. Pat13 thread starter macrumors newbie

    Joined:
    Mar 2, 2013
    #6
    Solved: I burned a bootable version of a startup disk to a partition of my ext hard drive from another computer and booted from there. I'll update if the framework issue arises again. Thanks for the help
     

Share This Page