Quicktime integration, subtitle problems

Discussion in 'Mac Apps and Mac App Store' started by Madpiper, Nov 12, 2008.

  1. Madpiper macrumors newbie

    Joined:
    Oct 2, 2008
    #1
    I am having some really annoying problems with quicktime. Here's my story, originally I just deleted quicktime and its plugins because I heard its a worthless player. I installed vlc, and its internet plugins. Which sort of worked. I was not a big fan of the buggy plugins though, so I decided I would give quicktime a shot again. My theory was, if it runs in quicktime, then it should in itunes and frontrow. So I downloaded quicktime again, and perian and flipformac. Well, the good news is that quicktime recognizes my .mkv and ogm files and plays them.

    The bad news is itunes wont open them at all. It wont even recognize them when I tried to place them in my Movies folder in itunes. Frontrow will play the videos, but will not show any picture displays in frontrow. But the really annoying part is the subtitles. Half of my videos are in japanese with english subtitles, the other half is in also in japanese with english subs, but has english dubs as well. But quicktime plays every single damn video with subtitles on, even if they are speaking english. I have tried to turn them off, but to of no avail. I dunno, is what I am wanting to do nuts or something? I really thought this would have been a common place thing to ask for, nothing complicated or annoying. :mad:

    I am looking for advice and guidance, so please, if anyone knows anything or has any input, I beg you to release it to me. I am truly out of ideas. :confused:
     
  2. jackerin macrumors 6502a

    Joined:
    Jun 29, 2008
    Location:
    Finland
    #2
    Perian is set to open all associated subtitle files by default. You can turn it off in the preferences panel, but then it won't load any. I can't really think of any one-stop solution to your problem since there's not really any way to tell Perian to not load subs for a particular file. (You *could* theoretically extract the audio and video streams and make a new file without subtitles embedded in the file, but that's a sort of overkill.)

    One possible solution is to acquire Quicktime Pro, then get movie properties, deactivate the subtitle layer and save as a reference file.

    Btw, deleting Quicktime Player just because you "heard its a worthless player" is a bit like cutting off the head because there's a zit on your nose. You can quite easily change file associations to open everything in VLC.
     
  3. Madpiper thread starter macrumors newbie

    Joined:
    Oct 2, 2008
    #3
    Thats just what I was told, and I am a minimalist. If I am not going to use it, I will get rid of it. I'm very anti-clutter, an old habit from my PC days.

    I am sad there is no real way to turn it off. Every other player I have used had that option. (VLC, BSplayer, Windows media player) I thought this would be a normal option. So I am shocked it seems not to be standard with quicktime. I thought I was just missing this option on my own, not that is simply doesn't exist? :confused:

    Well, I will give it a couple more days to see if anyone else has any ideas. Thanks for the input! :D
     
  4. Gattz macrumors regular

    Joined:
    Oct 20, 2008
    #4
    I also have a problem where I can't turn off subtitles because of the grayed out "Off." I really would like a fix for this.
     
  5. Madpiper thread starter macrumors newbie

    Joined:
    Oct 2, 2008

Share This Page