Quicktime is not working in Safari after leopard install.

Discussion in 'Mac Apps and Mac App Store' started by Noricat, Nov 6, 2007.

  1. Noricat macrumors newbie

    Joined:
    Nov 5, 2007
    #1
    Every time there is a quicktime file in a web page it will not play using Safari (3.0.4). Imbedded videos in youtube, Cnn video, Ect... Everything worked fine before the leopard install.
    I have tried reinstalling Flash and that did not work. Quicktime seems to be working fine outside Safari.

    Anyone have any ideas that might work?

    Thanks in advance for your help.
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    This is probably caused by your QuickTime browser plug-in either being missing or incompatible with the version of QuickTime you have installed. The easiest way to correct this is to download and install the latest QuickTime update, after deleting the old plug-ins (I think they are located in /Library/Internet Plugins but I am not 100% sure about that path), if they exist.
     
  3. Jaki macrumors newbie

    Joined:
    Dec 11, 2007
    #3
    solution to Quicktime question mark appearing after installation of Leopard

    Try the following steps:
    1) Open the folder Macintosh HD/Users/your_user/Library/Preferences
    2) In this folder, search the file com.apple.quicktime.plugin.preferences.plist
    3) Open it with Textedit
    4) Search for this string (without the quotes) "<key>application/x-shockwave-flash</key>"
    5) On this section, change the "<true/>" string to "<false/>" (without the quotes)
    6) Save and quit Textedit
    7) Relaunch Safari and ENJOY!!!!!
    8) After you follow these instructions, don't open the MIME Setup on the quicktime Preference Panel -> Advanced or you will revert the boolean back to yes (and will have to change it to no again). This is indeed a bug in Quicktime Preference Panel
     
  4. MacDaddi macrumors member

    MacDaddi

    Joined:
    Oct 29, 2007
    Location:
    San Francisco
    #4
    No More Problems With Quicktime Question Mark

    Hi, there everybody. After countless hours of searching through forums, trying all of the many temporary fixes i.e; deleting ~pref file, disabling flash in the quicktime preferences, disabling flash in the MIME (advanced QT settings), reinstalling flash, taking plugins out of the /Library/Internet Plug-Ins/ folder, I even opened the .plst file and changed something to </false>, which all worked temporarily, I finally found a good fix. Lets start with my problem...
    Safari and Firefox will not show Flash media. But if I use another user the browsers work fine...

    The fix... :mad:Do not move but COPY the flash plugins ( Flash Player.plugin and flashplayer.xpt) from Macintosh HD/Library/Internet Plug-Ins/ to.. ~/yourname/Library/Internet Plug-ins/ and restart your browser. This has worked for me and and I hope it will work until apple addresses this problem.:mad::apple:

    I hope this helps somebody. Good luck.
     
  5. MacDaddi macrumors member

    MacDaddi

    Joined:
    Oct 29, 2007
    Location:
    San Francisco
    #5
    P.s

    I also wanted to say that the fix submitted by Jaki does work and is a great fix.
     
  6. mdmagsamen macrumors newbie

    Joined:
    Jan 16, 2008
    #6
    quicktime not working in safari

    thanks macdaddy for the insight on getting safari to play quicktime. i copied the plugins and that also worked for me. thanks again:)
     
  7. grizz1803 macrumors newbie

    Joined:
    Feb 15, 2008
    #7
    new macbook pro

    I have a brand new macbook pro and i have tried to do what was said above, unfortunately it does no show x-shockwave in that list. I'm not sure if this a issue but i purchased and installed quicktime pro since then it hasn't worked, it also did not work prior to the pro install. Please advise. Appreciate the reply.
     

Share This Page