Quicktime opens all my music upon launch

Discussion in 'Mac Basics and Help' started by Live2Fish, Oct 20, 2015.

  1. Live2Fish macrumors newbie

    Live2Fish

    #1
    I have started using iPull to download videos to my hard drive to save - which works great. But when I want to watch the downloaded video, it will open all my mp3 music as soon as I want it to open the new video. Is there a way to set Quicktime (version 10.4) to NOT open my mp3's (I use iTunes for that), so that I can open ONLY videos with Quicktime? By the way, I'm using Yosemite on my MBP in case that matters. Thanks in advance!
     
  2. Live2Fish thread starter macrumors newbie

    Live2Fish

    #2
    I have tried searching online for the association answer and got nowhere. Maybe I can explain what I need better... My music normally opens in iTunes (maybe because that's where it's "stored" on the hard drive), but if I have a video that I want to watch - it will open with Quicktime, and when it does, it opens all my music as well. I just want quicktime to ONLY open videos, and not my music. But I can't find any settings for QT that will make this happen. Now maybe you guys can understand my question well enough to help a relatively new mac user? Thanks in advance!
     
  3. Live2Fish thread starter macrumors newbie

    Live2Fish

    #3
    Folks, I'm sure someone here knows how to help me with this issue. I get that I'm a mac dummy, but I'm here in the land of mac experts - I know somebody can help me with this. This should be an easy one for you mac pro's!
     
  4. red all over macrumors newbie

    red all over

    Joined:
    Mar 1, 2015
    Location:
    new york
    #4
    I'm totally not a pro, and may not have the right answer for you, but I know what it feels like to shout into the void.

    Have you tried right-clicking (control-clicking) (two-finger-clicking) on the music or movie file, and selecting "get info" from the drop down menu? If you do that, an information pane opens, with lots of metadata and information about the file and some adjustable options (some of these may be tucked away under disclosure triangles which need to be ticked open).

    One of them says "open with" and has a small window showing the current application designated to open this particular file. If you don't like the app that is selected, you can change it. If you do like it, you can keep it. And the part which would probably help you is the button underneath, which says "change all." So, if you like opening your movie file with VLC, you can click 'change all' and then any file that ends with .mkv or whatever you're choosing, will default to opening with VLC. The same thing applies to getting apps you don't want launching (by their exclusion).

    There may be something in iPull's preferences that has it defaulting to open mp3 with Quicktime. But if you tell your mac to always open mp3s with itunes, that should override iPulls settings. If not, it should be easy enough to go to iPulls preferences and turn off whatever the setting is for always open such and such with blah blah blah.

    I hope this helps. I'm about to ask for help here myself. Never thought I'd be answering a query.

    Red
     
  5. Live2Fish thread starter macrumors newbie

    Live2Fish

    #5
    Thanks Red. I appreciate your helpful answer. I did try the "file association" - using the MP3's as my "tester". They are already set to open with iTunes which is what I want. I think it's a quicktime quirk. I don't have VLC, but have downloaded Elmedia - which seems to be a good program (based on my one quick playback today). I'm thinking the easiest fix is just to delete Quicktime and be done with that program. I'm thinking that the program "DownloadHelper" for Firefox is a better option than the INCREDIBLY slow iPull program. So with DLH and Elmedia - maybe I'm set and there may not be an issue any longer. Still fiddling around with it to see... I hope you have better response to your question here than I have. I think this might have been my first question here, but not sure - but I can say that it certainly wasn't the quick answer fix I thought it would be!

    Thanks again - Sharon
     

Share This Page