Quicktime Player no longer works - Snowleopard mess it up?

Discussion in 'Mac Apps and Mac App Store' started by Ginger Vitas, Sep 8, 2009.

  1. Ginger Vitas macrumors newbie

    Joined:
    Aug 21, 2009
    #1
    I'm not sure why but ever since I loaded snowleopard I can't get any quicktime vids to play. If I do get it to open I get sound only, or usually I get the message, "QuickTime Player must be installed to run this application." However, I do have QuickTime Player installed - vers 10.0.

    I've had my macbook for 3 years and by far this is the biggest wtf is going on since I bought it. I love my mac, but what in the heck is going on? Help!
     
  2. Richard1028 macrumors 68000

    Joined:
    Jan 8, 2009
    #2
    You have the new QuickTime player. It's not quite ready for prime time.

    Insert your SL disk and install QT 7 (which is what you had before SL).
     
  3. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #3
    Have you installed perian or tried reinstalling it?
     
  4. Ginger Vitas thread starter macrumors newbie

    Joined:
    Aug 21, 2009
    #4
    Very cool. That worked. My 'old' quicktime is back and my downloads are opening up just fine. I don't even remember how I got that 'new' version on my computer...anyway, all's well that ends well.

    Thank you!
     
  5. MauiBaby macrumors newbie

    Joined:
    Aug 8, 2009
    #5
    Both QT 7 and X?

    I also installed SL and now my videos in iPhoto no longer play. Apple support said to install QT 7 from the website download and that I can have both QT 7 and QT X installed. Has anyone tried this? Will the both be available or will installing 7 get rid of X?
     

Share This Page