Mac Quicktime Player recording with Applescript broken on Mavericks?

hary536

macrumors newbie
Original poster
Mar 30, 2012
14
0
I have this simple code:

tell application "QuickTime Player"
activate
new screen recording
document "Screen Recording" start
delay 10
document "Screen Recording" stop
end tell

This records a 10-second movie on my 10.8 machine with no problem. But on 10.9 mac-mini, QT hangs at the stop action above. It hangs at the window with message "Finishing Recording". I have to force quit it and still same thing. If I do these steps manually, they work. But with AppleScript or even same steps with Automator have same issue.

I upgraded to 10.9.2, but still same issue.

Is this a known bug? Any suggestions for a work around?

Thanks.
 

hary536

macrumors newbie
Original poster
Mar 30, 2012
14
0
I'm seeing this same thing. Did you ever figure anything out?
I submitted a bug report to Apple through Apple bug report page.
They said it was a known issue. Haven't heard anything else after that.

Though, I did figure out a awkward workaround for this. Not totally flawless though. I don't remember what I did. But I will dig up my script and update it here.
 

bruss147

macrumors newbie
Mar 21, 2008
5
0
I figured out a workaround, too. I was about to post it, but seem to have not pushed to git from work. So, I don't have it until next week.

Basically, I used applescript to click button 1 of the Screen Recording window. Then I had to use cliclick utility I found from searching in order to click the screen to select fullscreen recording. Then stopping the video would work.
 

bruss147

macrumors newbie
Mar 21, 2008
5
0
Oh. Apparently my git UI hadn't refreshed. Here is my script:

Code:
tell application "QuickTime Player"
  activate
  new screen recording
  tell application "System Events" to tell application process "QuickTime Player" to tell window "Screen Recording"
    click button 1
  end tell
  delay 1
  do shell script "./cliclick c:10,10"
end tell
 
Last edited by a moderator:

VideoBeagle

macrumors 6502a
Aug 17, 2010
785
10
App Q&A testing by request.
There seems to be a problem with applescript control of Quicktime (I have a thread about export not working).

I also submitted a bug report that they closed saying it was a dupe issue.

Kryton2 tested my problem on the Yosemite beta and it's still broken there.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.