Quicktime Plugin Failure

Discussion in 'OS X Yosemite (10.10)' started by MacWorks916, May 7, 2015.

  1. MacWorks916 macrumors newbie

    Joined:
    Apr 4, 2015
    #1
    Ever since I've upgraded to Yosemite I'm getting "Plugin Failure" where QT media should be playing in Safari.

    I've identified a work-around, but it doesn't appear to be a consistent solution.

    When I go to Preferences in Safari I click on Security. I have the Allow checkbox checked for Internet plug-ins. When I click on Website Settings... a new screen pops up. On the left I click on Quicktime and the two sites I can't get QT files to play shows up on the right. At first I had "Allow Always" selected but would still get the plugin failure. So I selected "Run in Safe Mode" and can usually get the media to play properly. The problem is that setting doesn't always seem to hold. And why is it only these two sites require this?
     
  2. Bomb Bloke macrumors regular

    Bomb Bloke

    Joined:
    Feb 12, 2015
    Location:
    Tasmania (AU)
    #2
    Old versions of internet plugins (from non-Apple sources, typically) tend to stick around throughout OS updates, and when you hit the point where they're no longer compatible with whatever version of Safari you've ended up with, this sort of thing tends to happen.

    In particular, DivX extensions are notorious for messing with videos Quicktime would usually deal with correctly. If any happen to be present in your extensions panel, I suggest disabling them.

    Failing that, you'll likely have to dig in and check through Safari's plugin folders manually.

    You'll also likely notice a Quicktime folder in your Library(s) - certainly worth a peek in those while you're at it, as more troublesome plugins can lurk in those too.
     

Share This Page