quicktime pro and joining two movies problems

Discussion in 'Mac Apps and Mac App Store' started by kannonbal, Nov 20, 2006.

  1. kannonbal macrumors member

    Nov 20, 2006
    Hi all,

    I am attempting to join together a couple of image sequence movies and a couple of animations.

    I know how to set the sliders, select all, copy, paste, etc, etc.

    So, once I have the end result put together, flattened and saved as a self contained movie, I am experiencing some really strange playback problems.

    As the movie progresses from the end of the animation to the beginning of the image sequence, it will flash one frame of the end frame before the animation segment. But only sometimes....:(. If i go back to the middle of the animation and hit play, all will work fine. But if I start from the beginning, it will mess up every time.

    I have made sure that there is no single frame there, so obviously there is some kind of bug in quicktime, right?

    This is very annoying! I paid the $30, just for the ability to splice multiple movies together, but this glitch is driving me crazy.

    Any suggestions would be greatly appreciated!

    Thanks in advance
  2. liketom macrumors 601


    Apr 8, 2004
    let me guess intel mac mmm prob macbook 512mb ram?

    this happens sometimes in imovie under 512mb for me
  3. kannonbal thread starter macrumors member

    Nov 20, 2006
    yep, macbook pro. 2 gig of ram, though.

    That's weird that you have this happen in imovie, too.

    So it's not just a certain software issue, hmmmm.

    What do you do about it? 'm using these movies for my job, so this glitch is more than just an annoyance.

  4. liketom macrumors 601


    Apr 8, 2004
    this used to happen when i was on 512mb since went upto 768 - 1gb and no problems since - i'm sure it's to do with the memory VRAM and or RAM

    repair permissions ? and is it apple stock 2gb? or cheap memory

    i can see apple putting out an update for this

    EDIT: as a dirty fix i exported the movie to DV and closed it all down then re-imported it back again into iMovie that fixed it for me 9 out of 10 times anyway
  5. kannonbal thread starter macrumors member

    Nov 20, 2006
    It is stock Apple memory.

    The movie is 750MB, FWIW.

    I'm wondering if the interface between joining an image sequence (jpegs) and an h.264 encoded animation has anything to do with it.
    I've tried both inserting the animation inside the sequence and opening the first half of the sequence, then adding the animation to the end of it, and then adding the second half of the sequence.

    Maybe I'll try exporting the whole thing out as another movie without compressing it and see if that helps.

  6. kannonbal thread starter macrumors member

    Nov 20, 2006
  7. Sedwards macrumors newbie


    Aug 21, 2009
    Quicktime Pro


    I've just purchased Quicktime pro to join together a sequence of movies in Quicktime and I can't make sense of the controls - is there an idiots guide to this? I've also tried to import the sections into imovie and this doesn't work either. I appear to have wasted the price of Quicktime pro because it doesn't appear do anything that Quicktime doesn't do already!

    Please provide assistance if you can.

  8. sammich macrumors 601


    Sep 26, 2006
    Have you tried exporting it? You may be onto something when you say it's comprised of a couple of different codecs inside.
  9. jackerin macrumors 6502a

    Jun 29, 2008
    Open 1, select all, copy, close, new movie, paste.
    Open 2, select all, copy, close, paste into the new movie opened earlier.

    Regarding the other issue in this thread, some codecs, most notably MPEG-4 and derivatives, are heavily reliant on the file being played in sequence, since many of the frames are dependant on the ones that came before. (Look up keyframes to learn more about it.) This is most likely the cause of it.

Share This Page