Quicktime X - black screen when open

catachip

macrumors regular
Original poster
Jun 7, 2007
224
0
Vancouver, British Columbia
Hey folks,

I have snow leopard with all the updates. Sometime recently Quicktime X has started acting up on me. When I open videos in quicktime (can be mov, mpg, anything) it will often just show a black screen where the video would be. There is no sound or video. If I try to quit the program, it wont quit. If I reopen quicktime once or twice more, it will eventually start playing the video.

I have no idea what is going on. Anyone experience this or know of a fix?

Thanks!
 

ant-macyourself

macrumors member
Sep 1, 2008
82
0
Sorry to bring up a somewhat old topic, but this just started happening to me as well. I open a video in QuickTime X, get a black screen, then it freezes. Sometimes QuickTime 7 will work, sometimes it goes black & freezes too. From there QT will randomly alternate between playing the video like normal and not working. System restarts seem to have no effect.
 

catachip

macrumors regular
Original poster
Jun 7, 2007
224
0
Vancouver, British Columbia
Sorry to bring up a somewhat old topic, but this just started happening to me as well. I open a video in QuickTime X, get a black screen, then it freezes. Sometimes QuickTime 7 will work, sometimes it goes black & freezes too. From there QT will randomly alternate between playing the video like normal and not working. System restarts seem to have no effect.
Ha... I love it. I did a google search for this problem and found my old post. Great!

Anyone having this problem??? I did a reinstall and it still happens. Takes like 2-3 force quits to get quicktime to play the video.
 

stevemiller

macrumors 68000
Oct 27, 2008
1,733
1,164
Ugh this has been happening to me too, I also have installed Snow Leopard twice, both times clean install. There are admittedly far fewer glitches this time around, but this quicktime x bug is frustrating!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.