Quicktime X for avi files by default?

Discussion in 'macOS' started by superspiffy, Aug 28, 2009.

  1. superspiffy macrumors 6502a

    Joined:
    Feb 6, 2007
    #1
    How do you make Quicktime X be the default player for avi files? When I double click an avi file, Quicktime 7 opens up instead of Quicktime X. But double clicking on mp4s opens up Quicktime X with no problem.
     
  2. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #2
    Right click on your .avi file, select "open with" and then "Other."

    In there, select Quicktime X and at the bottom check the box "Always open with."
     
  3. superspiffy thread starter macrumors 6502a

    Joined:
    Feb 6, 2007
    #3
    That'll only work for that particular file and not every other avi file. how do you make it for ALL avi files?
     
  4. cinder macrumors member

    Joined:
    Jun 26, 2004
    Location:
    Seattle
    #4
    Get Info and select Quicktime X from the dropdown, then hit 'Change All . . ."

    (command+I or right click and select from the dropdown)


    (ha, i like how I'm still a newbie even though I've been here for 5 years :)
     
  5. Chundles macrumors G4

    Chundles

    Joined:
    Jul 4, 2005
    #5
    I have noticed a bug in Snow Leopard that disables the "Change All" in the Get Info window.

    To enable it you need to go to "Open With" and select "Other," navigate to Quicktime Player X and check the "Always Open With" box.

    THEN you need to bring up the Get Info window and the Change All button will now work for that file type.
     
  6. nlivo macrumors 6502a

    Joined:
    Jun 18, 2007
    Location:
    Ballarat, Australia
  7. superspiffy thread starter macrumors 6502a

    Joined:
    Feb 6, 2007
    #7
    with Perian...
     

Share This Page