Quirky stuff going on

Discussion in 'MacBook Pro' started by 8Apples, Jan 26, 2015.

  1. 8Apples macrumors member

    8Apples

    Joined:
    Nov 1, 2013
    #1
    I'm running a 13" MacBook Pro (Late 2011) model. I have upgraded when the new upgrades came out and am currently running the latest Yosemite with the latest updates. I have always upgraded and never re-installed, or wiped the hdd. Several years ago, I made a new user and moved all my files over to the new user to 'fix' issues I was having. I started experiencing some quirky things going on. So I did some maintenance steps. Using Disk Utility I checked the hdd (Check Disk), found errors, booted into recovery and fixed the disk (Repair Disk) issues. I also Checked permissions and found some errors. So I fixed those as well. I was trying to show a video through my Epson projector with this MBP and first of all the remote refused to work for me. The video (an mp4 made with iMovie) stopped and started randomly with Quick Time. It did this while I was playing the video too, just stopped 3 times in a 5 minute video. Very odd.

    Today I did more maintenance. I ran OnyX and did some serious cleanup and stuff. I mostly left it as default and ran most of the maintenance and cleanup things, I then rebooted. I have noticed that before my MBP was maxing out my 8GB of ram with nothing running (at idle with no apps open). I have knocked that down to a whopping 5-6GB with the cleanup. However Safari locked up on me, and refused to scroll up or down. Everything else worked. I then closed it and it is working now. However the next odd thing, was a 4 finger swipe to change 'desktops' just quit working for no reason! I have now rebooted again, and it seems to be working, but I'm seriously wondering is something else going on? No one has had physical access to my Mac, and I'm usually conscientious about security, but I'm wondering... is there something really going on I should be concerned about (read into that hacked). Am I suffering from Hardware failure that I haven't picked up yet? I'm completely backed up with more than one method, so I feel pretty secure about my very important data. Anyone have any thoughts? This is a 'work' machine for me. I would sure appreciate any rational thoughts. I really don't feel there is a need to reinstall, unless the security of the computer has been compromised.

    8Apples

    PS - I was logged into this website, tried to post, and it said I was not logged in. So I copied and pasted the data, logged back in, and am trying this again... again, that is quirky.

    ----------

    In addition, before doing maintenance, I had a few applications crash on me. Pages was one, Safari a few times. Now I just had another app crash on me. Usually my Mac has been stable, with very few apps crashing.

    8Apples
     
  2. Samuelsan2001 macrumors 603

    Joined:
    Oct 24, 2013
    #2
    Firstly RAM

    OSX uses all the RAM available to it since mavericks, unused RAM is wasted RAM and it is used as much as possible to keep the system fast. This means that it always shows as used on the new activity monitor the only thing you need to look at is the RAM pressure graph and swap used, as long as the pressure graph is green and swap used is very low then you have no RAM issues at all.

    It sounds like some sort of hardware failure to me but I couldn't tell you what from this information.
     
  3. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #3
    Not sure whether it's the HDD on its way out, or a SATA cable going to die, or you need to reinstall a clean copy of OS X.
     
  4. 8Apples thread starter macrumors member

    8Apples

    Joined:
    Nov 1, 2013
    #4
    Thank you for the replies! I too am wondering if the HDD is giving very early warning signs of an imminent HDD failure. I think I'm going on 3 years with this hdd, which is pretty average life span for a hdd. I followed this:

    http://macs.about.com/od/Troublesho...ternet-to-Diagnose-Problems-With-Your-Mac.htm

    to test hardware... The last part specifically "Using the Apple Hardware Test Over the Internet" and it came up clean. However, it didn't seem to show the hdd on the testing... or I over looked it. I ran both the simple version and the extended version. I have basically ruled out any other hardware, leaving me with either a sketchy hdd that is avoiding diagnostic tools, or certainly a software problem. Which at this point, I also have a hard time believing it could be software. RAM is still reporting 6GB of 8GB used (except when I do some serious work like video editing, then we get into swap). Which is probably the best it has been since upgrading to Yosemite. Unless someone can point me to the definitive end all free hdd check, I'm going to continue to kind of wait and watch and see how it goes. Again, thanks for the feedback. I will keep you posted.

    8Apples
     
  5. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #5
    AHT doesn't test a lot of things properly in my experience.

    It doesn't test the GPU (confirmed when testing on a Radeongate affected MBP), and it probably doesn't test the hard drive either.

    If it's the SATA cable, get a new cable. If the HDD is dying, you might want to reconsider buying an SSD instead.
     
  6. 8Apples thread starter macrumors member

    8Apples

    Joined:
    Nov 1, 2013
    #6
    Hmm, thanks for the feedback, although I would rather heard that AHT was more definitive. :) I do appreciate the reality that it isn't as great as it should be. I'm open to other free diagnostic tools.

    Right, could be the cable... although, I would think that hdd failure is more probable than cable failure. I mean, it hasn't been opened up and moved around which would degrade cables more than just running electricity through them. Not ruling that out, but that is hard to imagine for me. How could I distinguish cable from hdd failure without physically testing each individually (i.e. opening it up and swapping out the cable)?


    8Apples
     
  7. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #7
    You could try booting your HDD off a USB enclosure. If it starts up fine, say goodbye to your SATA cable.
     
  8. chipchen macrumors 6502

    Joined:
    Oct 30, 2002
    #8
    I recently came across some MBP 13" machines that had weird issues... turned out to be SATA cable... I couldn't believe it... but somehow they are going bad... I thought I was crazy until I found a bunch of people online saying the same thing. You COULD TRY taking the drive out and putting it in an enclosure to boot from... But then again the SATA cable could have corrupted the OS too...
     
  9. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #9
    Try SMARTUtility to check for bad sectors. Also try Memtest86 for bad RAM. Bad RAM can cause all kinds of random weird and wonky problems
     
  10. 8Apples thread starter macrumors member

    8Apples

    Joined:
    Nov 1, 2013
    #10
    As a followup, after a few days of running smoothly, I have only had one program crash on me. These are stable programs, not sketchy ones that would normally crash. I really appreciate the feedback on the cable. I'm starting to really wonder if the cable is the problem... especially with the 'randomness' that is going on. Software wise, my MBP is running the best it has in a while (I did a lot of maintenance to weed out software issues). I have run hardware checks and everything seems to be fine. Which seems to indicate probably a cable issue, or still possibly a hdd that is just starting to fail. I'm just going to continue to be aware of the problem and when I hit a point that it is more consistent, I will further look for a solution. Again thank you for the feedback.

    8Apples
     
  11. 8Apples thread starter macrumors member

    8Apples

    Joined:
    Nov 1, 2013
    #11
    Walked in the room to see my computer rebooting... that was odd, especially since I was out of the room when it crashed. Here is the crash report:
    Code:
    Anonymous UUID:       CDD0C6FF-1FB7-CAE2-CDFF-907ED5936E32
    
    Fri Jan 30 17:55:08 2015
    
    *** Panic Report ***
    panic(cpu 2 caller 0xffffff8023e1a46e): Kernel trap at 0xffffff8023b0e058, type 14=page fault, registers:
    CR0: 0x0000000080010033, CR2: 0xffffff815cac9000, CR3: 0x000000025a458041, CR4: 0x00000000000626e0
    RAX: 0x0000000000000c30, RBX: 0xffffff815cac9000, RCX: 0x0000000000000186, RDX: 0x0000000000000c30
    RSP: 0xffffff812e9f38e8, RBP: 0xffffff812e9f3930, RSI: 0xffffff815cac9000, RDI: 0xffffff81cc26d000
    R8:  0x0000000000000e00, R9:  0xffffff81cc26d000, R10: 0x0000000000100024, R11: 0x0000000000000000
    R12: 0xffffff81cc26d000, R13: 0x0000000000000164, R14: 0x0000000000000c40, R15: 0x0000000000000e00
    RFL: 0x0000000000010202, RIP: 0xffffff8023b0e058, CS:  0x0000000000000008, SS:  0x0000000000000010
    Fault CR2: 0xffffff815cac9000, Error code: 0x0000000000000000, Fault CPU: 0x2
    
    Backtrace (CPU 2), Frame : Return Address
    0xffffff812e9f3590 : 0xffffff8023d2fe41 
    0xffffff812e9f3610 : 0xffffff8023e1a46e 
    0xffffff812e9f37d0 : 0xffffff8023e36683 
    0xffffff812e9f37f0 : 0xffffff8023b0e058 
    0xffffff812e9f3930 : 0xffffff7fa60271d6 
    0xffffff812e9f39f0 : 0xffffff7fa6026ec1 
    0xffffff812e9f3a60 : 0xffffff7fa6011fb5 
    0xffffff812e9f3b30 : 0xffffff80243000a6 
    0xffffff812e9f3b60 : 0xffffff8024301268 
    0xffffff812e9f3bc0 : 0xffffff80242fe9c3 
    0xffffff812e9f3d00 : 0xffffff8023de4a87 
    0xffffff812e9f3e10 : 0xffffff8023d33f8c 
    0xffffff812e9f3e40 : 0xffffff8023d18a93 
    0xffffff812e9f3e90 : 0xffffff8023d293bd 
    0xffffff812e9f3f10 : 0xffffff8023e059fa 
    0xffffff812e9f3fb0 : 0xffffff8023e36ea6 
          Kernel Extensions in backtrace:
             com.apple.driver.AppleIntelHD3000Graphics(10.0)[BF767242-858E-3203-9CB4-AD9F54B1E6E3]@0xffffff7fa5ffe000->0xffffff7fa6064fff
                dependency: com.apple.iokit.IOPCIFamily(2.9)[56AD16B5-4F29-3F74-93E7-D492B3966DE2]@0xffffff7fa4524000
                dependency: com.apple.iokit.IOGraphicsFamily(2.4.1)[619F6C9F-0461-3BA1-A75F-53BB0F87ACD3]@0xffffff7fa4e83000
    
    BSD process name corresponding to current thread: WindowServer
    
    Mac OS version:
    14C109
    
    Kernel version:
    Darwin Kernel Version 14.1.0: Mon Dec 22 23:10:38 PST 2014; root:xnu-2782.10.72~2/RELEASE_X86_64
    Kernel UUID: DCF5C2D5-16AE-37F5-B2BE-ED127048DFF5
    Kernel slide:     0x0000000023a00000
    Kernel text base: 0xffffff8023c00000
    __HIB  text base: 0xffffff8023b00000
    System model name: MacBookPro8,1 (Mac-94245B3640C91C81)
    
    System uptime in nanoseconds: 87635118640428
    last loaded kext at 85455142020331: com.apple.driver.AppleUSBCDC	4.2.2b5 (addr 0xffffff7fa662d000, size 20480)
    last unloaded kext at 85925221834660: com.apple.iokit.IOUSBMassStorageClass	3.7.1 (addr 0xffffff7fa65f9000, size 69632)
    loaded kexts:
    foo.tap	1.0
    foo.tun	1.0
    com.epson.driver.EPSONProjectorUDAudio	1.30
    com.apple.filesystems.smbfs	3.0.0
    com.apple.driver.AppleBluetoothMultitouch	85.3
    com.apple.filesystems.afpfs	11.0
    com.apple.nke.asp-tcp	8.0.0
    com.apple.filesystems.udf	2.5
    com.apple.driver.AppleHWSensor	1.9.5d0
    com.apple.iokit.IOBluetoothSerialManager	4.3.2f6
    com.apple.driver.AGPM	100.15.5
    com.apple.filesystems.autofs	3.0
    com.apple.driver.AppleOSXWatchdog	1
    com.apple.driver.AppleMikeyHIDDriver	124
    com.apple.driver.AppleHDA	269.25
    com.apple.driver.AudioAUUC	1.70
    com.apple.driver.AppleSMCLMU	2.0.7d0
    com.apple.driver.AppleMikeyDriver	269.25
    com.apple.driver.AppleBacklight	170.5.0
    com.apple.iokit.IOUserEthernet	1.0.1
    com.apple.driver.AppleUpstreamUserClient	3.6.1
    com.apple.driver.ApplePolicyControl	3.8.6
    com.apple.driver.AppleThunderboltIP	2.0.2
    com.apple.driver.AppleMCCSControl	1.2.11
    com.apple.driver.AppleLPC	1.7.3
    com.apple.driver.ACPI_SMC_PlatformPlugin	1.0.0
    com.apple.driver.AppleSMCPDRC	1.0.0
    com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport	4.3.2f6
    com.apple.Dont_Steal_Mac_OS_X	7.0.0
    com.apple.driver.AppleHWAccess	1
    com.apple.driver.AppleHV	1
    com.apple.driver.AppleIntelHD3000Graphics	10.0.0
    com.apple.driver.AppleIntelSNBGraphicsFB	10.0.0
    com.apple.driver.SMCMotionSensor	3.0.4d1
    com.apple.driver.AppleUSBTCButtons	240.2
    com.apple.driver.AppleUSBTCKeyboard	240.2
    com.apple.driver.AppleIRController	327.5
    com.apple.AppleFSCompression.AppleFSCompressionTypeDataless	1.0.0d1
    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib	1.0.0d1
    com.apple.BootCache	35
    com.apple.iokit.SCSITaskUserClient	3.7.3
    com.apple.driver.XsanFilter	404
    com.apple.iokit.IOAHCIBlockStorage	2.7.0
    com.apple.driver.AppleUSBHub	705.4.2
    com.apple.driver.AirPort.Brcm4331	800.20.24
    com.apple.driver.AppleSDXC	1.6.5
    com.apple.driver.AppleFWOHCI	5.5.2
    com.apple.driver.AppleAHCIPort	3.1.0
    com.apple.driver.AppleUSBEHCI	705.4.14
    com.apple.iokit.AppleBCM5701Ethernet	10.1.3
    com.apple.driver.AppleSmartBatteryManager	161.0.0
    com.apple.driver.AppleACPIButtons	3.1
    com.apple.driver.AppleRTC	2.0
    com.apple.driver.AppleHPET	1.8
    com.apple.driver.AppleSMBIOS	2.1
    com.apple.driver.AppleACPIEC	3.1
    com.apple.driver.AppleAPIC	1.7
    com.apple.driver.AppleIntelCPUPowerManagementClient	218.0.0
    com.apple.nke.applicationfirewall	161
    com.apple.security.quarantine	3
    com.apple.security.TMSafetyNet	8
    com.apple.driver.AppleIntelCPUPowerManagement	218.0.0
    com.apple.driver.IOBluetoothHIDDriver	4.3.2f6
    com.apple.driver.AppleMultitouchDriver	262.33.1
    com.apple.security.SecureRemotePassword	1.0
    com.apple.iokit.IOSerialFamily	11
    com.apple.AppleGraphicsDeviceControl	3.8.6
    com.apple.kext.triggers	1.0
    com.apple.driver.DspFuncLib	269.25
    com.apple.kext.OSvKernDSPLib	1.15
    com.apple.driver.AppleHDAController	269.25
    com.apple.iokit.IOHDAFamily	269.25
    com.apple.iokit.IOFireWireIP	2.2.6
    com.apple.driver.AppleBacklightExpert	1.1.0
    com.apple.driver.AppleGraphicsControl	3.8.6
    com.apple.driver.IOPlatformPluginLegacy	1.0.0
    com.apple.driver.IOPlatformPluginFamily	5.8.1d38
    com.apple.iokit.IOBluetoothHostControllerUSBTransport	4.3.2f6
    com.apple.iokit.IOSurface	97
    com.apple.iokit.IOBluetoothFamily	4.3.2f6
    com.apple.iokit.IOAudioFamily	203.3
    com.apple.vecLib.kext	1.2.0
    com.apple.driver.AppleSMBusController	1.0.13d1
    com.apple.driver.AppleSMBusPCI	1.0.12d1
    com.apple.iokit.IOUSBUserClient	705.4.0
    com.apple.iokit.IONDRVSupport	2.4.1
    com.apple.iokit.IOGraphicsFamily	2.4.1
    com.apple.driver.AppleSMC	3.1.9
    com.apple.driver.AppleUSBMultitouch	245.2
    com.apple.iokit.IOUSBHIDDriver	705.4.0
    com.apple.driver.AppleUSBMergeNub	705.4.0
    com.apple.driver.AppleUSBComposite	705.4.9
    com.apple.driver.CoreStorage	471.10.6
    com.apple.iokit.IOSCSIMultimediaCommandsDevice	3.7.3
    com.apple.iokit.IOBDStorageFamily	1.7
    com.apple.iokit.IODVDStorageFamily	1.7.1
    com.apple.iokit.IOCDStorageFamily	1.7.1
    com.apple.driver.AppleThunderboltDPInAdapter	4.0.6
    com.apple.driver.AppleThunderboltDPAdapterFamily	4.0.6
    com.apple.driver.AppleThunderboltPCIDownAdapter	2.0.2
    com.apple.iokit.IOAHCISerialATAPI	2.6.1
    com.apple.iokit.IOSCSIArchitectureModelFamily	3.7.3
    com.apple.driver.AppleThunderboltNHI	3.1.7
    com.apple.iokit.IOThunderboltFamily	4.2.1
    com.apple.iokit.IO80211Family	710.55
    com.apple.iokit.IOFireWireFamily	4.5.6
    com.apple.iokit.IOAHCIFamily	2.7.5
    com.apple.iokit.IOEthernetAVBController	1.0.3b3
    com.apple.driver.mDNSOffloadUserClient	1.0.1b8
    com.apple.iokit.IONetworkingFamily	3.2
    com.apple.iokit.IOUSBFamily	710.4.14
    com.apple.driver.AppleEFINVRAM	2.0
    com.apple.driver.AppleEFIRuntime	2.0
    com.apple.iokit.IOHIDFamily	2.0.0
    com.apple.iokit.IOSMBusFamily	1.1
    com.apple.security.sandbox	300.0
    com.apple.kext.AppleMatch	1.0.0d1
    com.apple.driver.AppleKeyStore	2
    com.apple.driver.AppleMobileFileIntegrity	1.0.5
    com.apple.driver.AppleCredentialManager	1.0
    com.apple.driver.DiskImages	396
    com.apple.iokit.IOStorageFamily	2.0
    com.apple.iokit.IOReportFamily	31
    com.apple.driver.AppleFDEKeyStore	28.30
    com.apple.driver.AppleACPIPlatform	3.1
    com.apple.iokit.IOPCIFamily	2.9
    com.apple.iokit.IOACPIFamily	1.4
    com.apple.kec.Libm	1
    com.apple.kec.pthread	1
    com.apple.kec.corecrypto	1.0
    Unable to gather system configuration information.
    
    
    Anyone code with error reports that can give me some facts on this??? :eek: :confused:

    8Apples
     
  12. 8Apples thread starter macrumors member

    8Apples

    Joined:
    Nov 1, 2013
    #12
    Ugghhh, checked the disk for errors got this:

    Code:
    
    Verifying file system.
     Using live mode.Performing live verification.
     Checking Journaled HFS Plus volume.
     Checking extents overflow file.
    Incorrect block count for file global-messages-db.sqlite(It should be 2328 instead of 61208)
    Incorrect block count for file BaptistListIncorrect block count for file INBOX(It should be 22529 instead of 35729)
    Incorrect block count for file Sent-1(It should be 22529 instead of 28332)
    Incorrect block count for file Trash(It should be 119 instead of 5402)
    Incorrect block count for file All Mail-1(It should be 5633 instead of 1084042)
    Incorrect block count for file All Mail-1.msf(It should be 6296 instead of 6560)(It should be 7871 instead of 10998)
    Checking multi-linked files.
    Checking catalog hierarchy.
     Checking extended attributes file.
    Volume bitmap needs minor repair for orphaned blocks
    Checking volume information.Invalid volume free block count(It should be 51069373 instead of 49859550)
    The volume Macintosh HD was found corrupt and needs to be repaired.
    The volume Macintosh HD was found corrupt and needs to be repaired.
    File system check exit code is 8.
    Error: This disk needs to be repaired using the Recovery HD. Restart your computer, holding down the Command key and the R key until you see the Apple logo. When the OS X Utilities window appears, choose Disk Utility.
    
    I know how to repair it, however, I'm still diagnosing. These errors all pertain to my Mail app, so probably when the 'shutdown error' see above post occurred it corrupted mail folders and database?

    I really can't troubleshoot the cable, because I don't have a hard disk enclosure to put the disk into and run off of. Is there a better way to really know if the cable is bad? It looked pretty in-depth to swap it out, not a simple cable change. Could this be a software issue still? I'm really considering wiping and re-installing, just to eliminate that. Thoughts???

    8Apples
     
  13. chipchen macrumors 6502

    Joined:
    Oct 30, 2002
    #13
    Yea, there really isn't a better way. You're at this point where if the cable is bad, it can be causing issues with the software, etc... and so even with a cable swap, it's possible you'll still have issues due to corrupted software.

    You're really better off doing the full wipe and install... And if you still have issues, it's almost definitely the cable. Whatever you do, you're going to have a better week than Pete Carroll though.
     
  14. 8Apples, Feb 2, 2015
    Last edited: Feb 2, 2015

    8Apples thread starter macrumors member

    8Apples

    Joined:
    Nov 1, 2013
    #14
    Ok, for a complete software restore plan...

    1. Wipe hdd and reinstall from the Recovery Partition.

    2. Now the tricky part... Restore my files

    A. Restore data from Time Machine (it's great for a quick easy file recovery, but get's messy to restore everything).

    OR

    B. Restore data from Carbon Copy Cloner

    Last time I created a new user, I was advised to simply copy the data over, instead of restoring, so I don't restore any previous corrupt library files or other database type stuff. I'm certainly open for options.

    Thanks for the help with this! I appreciate it!

    8Apples

    PS - I ran Linux as my primary OS for quite a few years, and had a nice easy solution, my user data was on a separate partition from the OS, this made it easy and convenient to upgrade, wipe or restore the OS. I'm know that is not my case here. Would the actual OS files themselves be corrupted, or user data in Library?
     
  15. 8Apples thread starter macrumors member

    8Apples

    Joined:
    Nov 1, 2013
    #15
    For anyone out there that may be curious.... NEVER use wifi to do a full system restore after wiping your data, and reinstalling the OS. It has run all night, and there are still 4 hours to go! Painstakingly sloooooooow.

    I chose to restore all my data via Time Machine, but not the apps... So I will still have to go in and install the apps I use. Arrgh, slowness.... Yes my fault. :eek: :eek:

    8Apples
     
  16. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #16
    Only if your internet is slow, obviously.
     
  17. 8Apples thread starter macrumors member

    8Apples

    Joined:
    Nov 1, 2013
    #17
    No this is all in house... A usb disk connected to my AirPort Extreme router. I'm connected via wifi. I should have unplugged the disk, brought it in here and did a restore directly from the usb disk, not over wifi. There is no cancel button either.

    8Apples
     
  18. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #18
    I've heard that USB media attached to Airport Extreme/Time Capsule tends to be very slow. It's probably faster to download directly from Apple.
     
  19. 8Apples thread starter macrumors member

    8Apples

    Joined:
    Nov 1, 2013
    #19
    This was to only restore all my data. I had already downloaded the OS from online and installed it. It took forever to restore my user data from my Time Machine backup that was connected to my Airport Extreme router. That was dumb on my part. I guess I wasn't as clear as I thought on that. At any rate, back up and running finally. Hopefully this will fix all issues. Appreciate the helpful insight of those who posted. Thanks!

    8Apples
     

Share This Page