Quite Odd KP occurances w/12" PB 1.33

Discussion in 'Macintosh Computers' started by d4nn0, Dec 16, 2005.

  1. d4nn0 macrumors member


    Dec 15, 2005
    Hey guys
    Got a bit of an interesting occurance with my Powerbook G4 12" 1.33. Quite a while ago I dropped my bag with it inside, causing the corner of the frame to bend a bit and make it difficult to plug the power in, and make it stay. Finally, I decided to open it up and try to bend the frame back with the help of pbfixit. To my shock and horror, as I was unscrewing the keyboard from the underneith, I'm pretty sure I shocked the logic board where there it pokes through beside the RAM expansion slot :eek: I nervously put it all back together, and to my delight, it worked. Or did it?

    My first KP occured while running tiger. I was unplugging the power, and as it changed power saving modes it crashed. I thought "oh well Ill just have to deal with this", but it turned out to not be such a regular occurance. KP's started happening with more frequency, in random places. Power plugged in or battery, many apps open or just a few. Highly frustrating. Unfortunately at this point I hadn't read about the log file so I didn't actually look at what the error messages were...

    In desperation earlier today, I installed panther to see if that might somehow work. To my dismay, about 30 minutes after installing it I received another KP while just idling. At this point I started searching the forum, and figured out how to get the logs. Here is the one from that time:

    Thu Dec 15 15:11:51 2005

    panic(cpu 0): Uncorrectable machine check: pc = 0000000022715B38, msr = 0000000000149030, dsisr = 40000000, dar = 00000000173CA004
    AsyncSrc = 0000000000000000, CoreFIR = 0000000000000000
    L2FIR = 0000000000000000, BusFir = 0000000000000000

    Latest stack backtrace for cpu 0:
    0x000837BC 0x00083CA0 0x0001EDA4 0x00091734 0x00090A20 0x0009416C
    Proceeding back via exception chain:
    Exception state (sv=0x33D6B000)
    PC=0x22715B38; MSR=0x00149030; DAR=0x173CA004; DSISR=0x40000000; LR=0x22724828; R1=0x0D1BBD20; XCP=0x00000008 (0x200 - Machine check)
    0x002644A8 0x22724828 0x002618AC 0x0026078C 0x002606F0
    Kernel loadable modules in backtrace (with dependencies):
    dependency: com.apple.iokit.IOPCIFamily(1.4)@0x183d7000
    dependency: com.apple.iokit.IONetworkingFamily(1.4.0)@0x1b14b000
    Exception state (sv=0x1B583A00)
    PC=0x00000000; MSR=0x0000D030; DAR=0x00000000; DSISR=0x00000000; LR=0x00000000; R1=0x00000000; XCP=0x00000000 (Unknown)

    Kernel version:
    Darwin Kernel Version 7.3.1:
    Mon Mar 22 21:48:41 PST 2004; root:xnu/xnu-517.4.12.obj~2/RELEASE_PPC


    Airport?? I was most confused... The strangest part of all was that after rebooting from that KP it has run perfectly for 9 hours, something it hasn't done since before I opened it up. Before I opened it up it has only ever seen one KP. The Apple Hardware Test showed everything as being fine, although I know that this isn't always true..

    Any ideas guys?? Sorry about my long-windedness...
    Many thanks,
  2. cluthz macrumors 68040


    Jun 15, 2004
    Try starting your machine holding down option(alt) with the original startup CD and start "apple hardware test" it migth give you a clue.
  3. d4nn0 thread starter macrumors member


    Dec 15, 2005
    nope... tried it before and everything passed
  4. sakasune macrumors member

    Mar 12, 2004
    I happened to have a bad processor on my Dual 2.0 G5 a while back and everytime I reviewed the crash log after a KP, it mentioned the airport and the networking family. I ran hardware test after hardware test and they came up clean. I finally brought it to an Apple store and they told me a processor must have died or the logic board was dying (after bringing it to a so-called Certfied Apple Specialist and they told me it was a software issue...but that's another story). They replaced the bad processor and all was good.
    My advice - hardware issues aren't easily fixable at home, bring it to an apple store if you're still in warranty or have applecare.
  5. d4nn0 thread starter macrumors member


    Dec 15, 2005
    thanks for the advice... unfortunately warranty was up in july, but luckily it's still working fine... it's as if it worked the problem out of its system or something haha. I'm just gonna hope that I keep having good luck and wait for the mactels :cool:

Share This Page