Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors newbie
Original poster
Apr 12, 2014
I'm having issues trying to connect to RabbitMQ server using SSL. I believe it is purely Mac OS issue. For certain time I've been unable to connect to the customer's RabbitMQ host from my Mac workstation and I suspected it was due to some new VPN policy setting, so I decided to run my own broker in my network. It worked fine, until I've turned on SSL on the server. I've got really loose settings regarding certificate validation - both client and server side, but each time I try to connect using EasyNetQ I'm receiving Interop+AppleCrypto+SslException: insufficient security exception.

Finally I executed the same code on Windows machine and it worked. Both sides use TLSv1.2 being secure certainly, but there have to be some setting within MacOS that prevents my application to communicate via SSL/TLS.

Has anyone experienced similar case?

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.