Raid 0 Controller Failure

Discussion in 'Mac Accessories' started by spiderbiz, Jan 25, 2013.

  1. spiderbiz, Jan 25, 2013
    Last edited: Jan 25, 2013

    spiderbiz macrumors newbie

    Jul 1, 2009
    I need some help. I had purchased an external G Tech 2tb drive and set it up as Raid 0. It had 2 1tb drives in the enclosure.
    Everything ran great for 3 years and as soon as I started having an issue - I ran out and purchased a new 4tb external.
    Before I could dump everything over to the new drive - my 2tb crashed.
    The drives are good - just the controller card went bad.
    I tried to locate the exact same controller ( i.e. Oxford 936d chipset ) but could not find that specific controller.
    What should I do? Am I stuck with trying to find a new controller or is there some software I can purchase that will ignore the controller and let me just restore my drives to get the data off of them?
    My whole life is on those drives and I really do need to get it back.
    Please advise.
    Any help is greatly appreciated.
  2. paulrbeers macrumors 68040

    Dec 17, 2009
    Maybe you shouldn't have used RAID 0 since "your whole life was on these drives".....

    How do you know that the drives aren't the culprit? Rarely do I see controller failures, but after 3 years you can see a lot of mechanical drive failures.
  3. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
    RAID is not a backup, remember that kids. You gambled and lost.

    Contact G-Tech and see if they can offer advice on a compatible controller.

    As paulrbeers mentioned, it's more likely one of the HDDs. In RAID 0 any drive failure will result in complete data loss as information is striped across the drives.
  4. drsox macrumors 65816


    Apr 29, 2011
    My advise to you is to look for an exactly similar GTech drive and see if your current drives can be moved intact.

    To validate this, you need to be sure from GTech that this will actually work.
    Maybe GTech can advise on repairing the drive also.

    Is there a GTech product forum you can ask ? Yes, there is : Ask there also.
  5. paulrbeers macrumors 68040

    Dec 17, 2009
    And RAID 0 shouldn't even be considered RAID (no redundancy!!).... Whoever decided that Striping should be called RAID 0 should be punched.
  6. spiderbiz thread starter macrumors newbie

    Jul 1, 2009
    Thanks for information I already knew

    Anyone that fails at something is not looking for "the hindsight comment" as a response but instead maybe an answer to what you should have done. So with that said, I was hoping someone might have had a similar issue and could tell me if there is software that will ignore the controller and just let me read the Raid 0 and continue with a restore.
    I am not a Raid experienced person. When I purchased that drive it recommended Raid 0 to get the full capacity of the drive. Duh. No room for any backup at all. I get that now. The "damage" so to speak is done - I just need an idea of where to go from here.


    I cannot guarantee that the drives are not the issue but they sound ( spin-up ) fine. The controller fails when I try to connect to my Macbook Pro via firewire.
    It says "controller failure" so I am making the assumption that the problem lies there.
    I have checked multiple other forums and failed controllers are not uncommon.
    But again, I am trusting those I talk to on these forums.
    For those giving positive feed back.


    The actual drive I had was a Duo-Pro which was built by Hitachi which now is G Tech ( owned by Hitachi ).
    I have talked with them and they don't have a clue what I should do.
    I need a controller with the same chip set but finding that is a major endeavor as well.
    I might mention that when I connect to my Mac and it does not recognize the drives. I can still go into the disk utility and see those drives there - it just doesn't recognize the Raid array.
  7. paulrbeers macrumors 68040

    Dec 17, 2009
    So wait, your computer can even see the drives in the external enclosure, just not the RAID huh? I'm going to be honest with you then, it doesn't sound like a controller failure. It sounds like had a write fault in one of your drives and thus the RAID was destroyed. My guess is that you could grab any two hard drives, throw them in the enclosure and it would work just fine. Obviously this is just my guess without seeing what you are seeing, but if you truly had a controller failure the drives wouldn't even be seen by the OS because the hardware would be dead to make it appear to OSX. You have a hard drive failure.
  8. chrfr macrumors 604

    Jul 11, 2009
    Not possible. The controller is what determines how the data is written to the disks. Your data is likely gone, unfortunately.
  9. marzer macrumors 65816


    Nov 14, 2009
    Your best bet is to look for a data recovery service that can handle RAID 0 recovery. It could be pricey but sounds like you really want the data back.

    One thing for sure. You need a backup solution from here forward. Go get a 3tb external to use for your primary data and use the 4tb to back up it and your computer.

    If you find a service that can recover your data, just let them restore it to your new 3tb.
  10. flynz4 macrumors 68040

    Aug 9, 2009
    Portland, OR
    Realistically... RAID 1/5/10 is not that much safer... certainly not to have a backup solution. They can keep you running in some failure modes... but they also introduce a bunch of new failure modes as well.

    As many have said. RAID (of any flavor) is not backup. You should always double backup your data irrespective of what type of RAID you choose.

    I am really sorry for the OP... a data recovery service may be the only option. You will have to determine if your data is worth it. I would make a last ditch effort to acquire an exact model RAID box... right down to the specific firmware level.


Share This Page