Raid and transfer rate question

Discussion in 'Mac Pro' started by speakerwizard, Oct 17, 2009.

  1. speakerwizard macrumors 68000

    speakerwizard

    Joined:
    Aug 8, 2006
    Location:
    London
    #1
    Hi, ive had 2 750gb 7200rpm drives striped raided for a while for my media and all has been fine, just upgraded to 2 x 5200rpm 1.5tb wd and transferring over the data (from my external) seems extremely slow, comparison with test file:
    from external to 7200rpm boot drive : 24seconds
    from external to striped drives: 1min

    now i know a 7200rpm drive is faster than a 5200rpm obviously but both the boot drive and the raided drives are both faster than firewire 800 anyway so it should be the same transfer rate no? also when doing just the 1 file it slows towards the end, could it be a sustained transfer rate problem? anyway thank for any advise.
     
  2. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #2
    You really don't give enough to go on, but I'll take a stab at it anyway.

    It's likely the interface you're using, but you don't say what it is. USB is the worst, and FW400 isn't much better (FW800 = 100MB/s max). The types of file access makes a difference also. Random access will be the slowest, as the heads have to move the most. Then you have to take in the seek times associated with each drive. It can get complicated.

    In general however, to get any more than that, you need to go with eSATA (375MB/s max). At least the interface is faster than a pair of mechanical drives can produce in a stripe set.
     
  3. speakerwizard thread starter macrumors 68000

    speakerwizard

    Joined:
    Aug 8, 2006
    Location:
    London
    #3
    Hi, thanks for the reply but one of the drives was a dud, i didnt even think to try them individually 1st so it was filling up till half way then slowing to a crall, strange cause they both passed s.m.a.r.t but one was just really really slow (tried in 2 bays to be sure) so returned it now, thank anyway though
     
  4. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #4
    Oops. :eek: :p

    I didn't even think to ask if you had verified each of the drives, as I had assumed they were good. How foolish of me... :p It's a really good habit to get into before attempting to create a RAID set. Not only will it locate DOA's, but those with lots of bad sectors, and check the firmware revisions (rather important if attached to a proper RAID card, as you have to make sure the firmware is compatible as well as the drive).
     

Share This Page