RAID1 with external USB3 drives causing kernel panics

Discussion in 'macOS' started by Krinkle, Mar 14, 2012.

  1. Krinkle macrumors newbie

    Joined:
    Mar 14, 2012
    #1
    Hey all,

    I've got a MacBook Pro (mid-2011) running Lion (up to date). I'm using FileVault encryption on the Macintosh HD drive.

    Recently I've bought two USB3 portable (no power cable needed) external disk drives (both 1TB). One by LaCie and one by Iomega.

    I set one up with TimeMachine (using provided encryption options as well) and the other blank. And seems to be working fine.

    Today I thought I'd go extra protective and use RAID1 to have redundancy as well as back up. I wanted to RAID1 Mirror the Time Machine backup from one external drive to the other.

    I found out I had to clear it first, so I gave up on the backups I had so far and cleared it. Then set up the RAID Mirror but then this problem showed up.

    While it was initializing (one drive just got it's new "Slice 1 of RAID Mirror" label in the sidebar of the Disk Utility) I got a kernel panic. Hadn't gotten that ever with this machine.

    So I shutdown and reboot but after the initial FileVault (before OSX boots), I get a kernel panic again. This time not a regular overlay but also a lot of Unix-flavor codes are shown between the grey Apple screen and the kernel panic layer.

    Rebooting again gave the same result. Disconnecting the drives got me into OSX properly, but after starting Disk Utility and connecting the drives again, it went for another kernel panic. Tried several times but no luck, can't get those drives to do pretty much anything.

    Any advice? Would like at least be being able to run Time Machine again (without RAID 1) and using the other drive for regular storage.

    Thanks in advance.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    I think you mean USB 2.0, since current Macs don't support USB 3.0.
     
  3. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #3
    Why not use CarbonCopyCloner or SuperDuper! to clone the TM backup to the other drive, as RAID might be a bit complicated as it seems?

    Like this for example:
    [​IMG]
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    He said he bought USB3 drives. What does that have to do with Macs supporting only USB2.
     
  5. Krinkle thread starter macrumors newbie

    Joined:
    Mar 14, 2012
    #5
    I did in fact buy two USB3 drives. Both are known and advertised to be perfectly compatible with USB 2.0. And from experience I know they are.


    Yeah, when I saw the first kernel panic my first intention was to get the drives working, erase them and use CCC instead.

    However my first concern is actually getting the drives to work.

    If I connect either or both and boot the MacBook Pro, it'll go into kernel panic early in the boot with a bunch of Unix errors. If I connect either or both after the OS has started, the same happens as well.

    Today I tried plugging them into another machine but it seems almost infective, those Macs instantly went into kernel panic as well.

    After a little researching on the internet I found several other people experiencing similar symptoms. However they had in common that they set the RAID Block Size to 256 K. I didn't intend to set it that high for any reason, but I was presented a choice so I thought I'd go with the bigger options. I think that high a block size is too big for the machine to handle on the fly with lots of data being pumped into Time Machine.

    I went to an Apple Premium Reseller nearby and they plugged the drives into a Mac Pro, it seemed it didn't crash right away (only after a minute or 2). After a quick reboot we started Disk Utility and immediately after it mounted hurry into "Erase" and blank it as quick as possible. This was successful for both drives and now they're working again.

    I could consider re-trying the RAID1 mirror with a smaller block size however I've been told that RAID1 isn't optimal nor meant to be used with external drives (especially not over USB). It's meant to be used with internal drives that enjoy an internal high-speed connection.

    So I've got the following working now and I'll leave it at that:
    * Erased both
    * One is attached all the time as Time Machine backup
    * The other is connected once a day to sync the Time Machine drive to it with CarbonCopyCloner
     
  6. dctomm macrumors newbie

    Joined:
    Apr 12, 2012
    Location:
    San Jose CA
    #6
    cannot set up a raid on lion with iomega disks

    I have exactly the same problem. i have a mac mini running lion. i bought 2 iomega 500G helium drives that i wanted to configure as a RAID. after formatting the disks, i attempted to set up the raid using disk utility, but during this procedure i got the grey screen of death. each time i tried to restart the computer i got a kernel panic. the computer was not usable with the disks plugged in.

    does setting up a RAID simply not work in lion? or is this a problem with iomega disks? will i be able to set up a RAID with other disks?

     

Share This Page