RAM Advice for UMBP 15

Discussion in 'MacBook Pro' started by ooninay, Apr 1, 2009.

  1. ooninay macrumors member

    Joined:
    Mar 19, 2009
    Location:
    Toronto
    #1
    Hi there,

    Looking for advice on RAM for the UMPB 15. I bought it with the stock 2 GB and bought 4 GB of OCZ RAM (2 x 2GB), intending to replace the stock RAM with the new ones. Computer will not boot with the new memory in it. However, if I put only one of the new sticks in and keep one of the old ones (for 3 GB total), it usually boots and runs pretty fine for the most part, but with occasional lockups and other weirdness (about once a day). It doesn't matter which of the new sticks I put in or which of the old ones I keep in; the behaviour is the same. Computer is perfectly stable with only the stock 2 GB. Is the new RAM flaky or is it a problem with the UMBP? I read that they are sometimes quirky with new memory but am not seeing much followup on that in the various forums. Not sure whether to try a different brand of RAM or wait for an Apple fix...?
     
  2. archangel37 macrumors member

    Joined:
    Apr 1, 2005
    #2
    Very strange. I ordered a 4gb kit from www.macsales.com (Other World Computing) and one of the sticks didn't work - I sent it back and got a new one that works fine.

    Macsales, by the way, is a very reputable mac-centric online retailer - I highly recommend buying from them in the future.
     
  3. Momofthree macrumors member

    Joined:
    Mar 11, 2009
    Location:
    in the desert
    #3
    I bought the 4gb package of Crucial memory (actually ordered it as a kit through Amazon) and mine works fine. haven't had any of the things happen that you have mentioned (knock on wood)
     
  4. ooninay thread starter macrumors member

    Joined:
    Mar 19, 2009
    Location:
    Toronto
    #4
    Perhaps I should just try again with a different brand and/or supplier. Thanks you both!
     

Share This Page