RAM Issue

Discussion in 'iMac' started by mulvi74, Apr 17, 2013.

  1. mulvi74 macrumors newbie

    Joined:
    Apr 17, 2013
    #1
    Long time lurker, first time poster.
    I have 2 pretty much identical 27" 2011 imacs. Until last week, both were running 8GB of DDR3 1333 RAM in 4 x 2GB
    I decided to upgrade both to 16GB in the form of 2 x 8 GB using the Patriot Mac RAM that is also working fine in a MBP (2011 also)
    The RAM installed no problems at all on my home one, on my work one it kept on rebooting itself with the very quick kernel error message flashing up (basically not getting past white boot up screen)
    So I thought the RAM was faulty, took it back, tried another set and same issue.
    I took the new sticks and tried them on my home iMac and it installed no problems (meaning at home I have 32GB in 4 x 8GB)
    Why is my work iMac rejecting the same RAM. Same model iMacs, virtually same config but continually giving me a kernel error ? As an aside another girl at work has 4 x 4GB DDR3 1066 sticks that i put in mine to test and that worked fine so there is nothing wrong with the slots or the original 2 x 8GB sticks
    I'm running 8GB on the office iMac (back to original 4 x 2GB) but cannot for the life of me figure out why it is rejecting the 8GB sticks
     
  2. bflowers macrumors 6502a

    Joined:
    Jul 19, 2006
    #2
    If I understand correctly, you had 8 (4GBx2) in each computer, and you were replacing that with 16 (8x2). Then, since this didnt work, you put all 4 into your home computer. Have you tried taking the RAM you removed from your home machine, and add it to the work one, thus giving you 16 (4x4)? Also, try the straight 32 (8x8) at work.

    Also, given that it is a kernel panic, I assume it is passing the start up self test? Do you hear the normal chime? Try reinstalling the OS, and make sure it is completely up to date.

    Try those things and let us know the results.
     
  3. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #3
    No need to reinstall, has nothing to do with this.

    OP, try resetting both PRAM/NVRAM and SMC, this might solve the problem.
     
  4. bflowers macrumors 6502a

    Joined:
    Jul 19, 2006
    #4
    True, I forgot to suggest resetting the PRAM. Though, a clean OS install is never bad advice. Kernel panics are related to the OS, thus, it was appropriate advice for the OP's issue.

    A snippet from Apple's Support pages:
     
  5. mulvi74 thread starter macrumors newbie

    Joined:
    Apr 17, 2013
    #5
    Ram

    I have 2 identical iMacs. One at home, one at work.
    Both were running 4 x 2GB RAM .. same models, same configs
    I bought a 16GB kit (8GB x 2) for each. Installed into the home one fine, the kernal panic and non boot thing on the work one. Took the 16GB one meant for work and installed it at home (thus the RAM itself is not faulty) and as such at home I am running 4 x 8GB (32GB)
    The work Mac now has its original 4 x 2GB sticks in and boots fine
    What i don't get is why 2 different sets of 16GB kits have failed to install into the work machine ? All software is up to date etc
     

Share This Page