Ram problem?

Discussion in 'MacBook' started by jeebob2112, Feb 16, 2012.

  1. jeebob2112 macrumors newbie

    Joined:
    Feb 16, 2012
    #1
    Haven't seen a post about this exact problem so I figured I'd give this a try.

    A few days ago, I was having trouble with my macbook (2nd gen I think). It was constantly needing to be restarted before it gave up entirely and wouldn't start up at all. I tried troubleshooting and found that it worked fine after removing one of the ram sticks. So I bought new ram hoping it was really this simple. After installing both sticks, the computer started fine and ran without any problems. However, as soon as I replaced the battery, the computer would no longer start up. Removed the battery and it was fine. So I removed the new ram from the slot that was originally giving me problems and suddenly the computer runs fine with or without the battery. Any suggestions?
     
  2. arjen92 macrumors 65816

    arjen92

    Joined:
    Sep 9, 2008
    Location:
    Below sea level
    #2
    mmm, that sounds weird. Just to be sure, you reset PRAM and NVRAM?

    I have heard people say to unplug the mac (for a minute) to drain the RAM from power. It makes sure the memory is really empty. Perhaps this is what happens when you remove the battery.
     
  3. farmhillbob macrumors newbie

    Joined:
    Feb 13, 2012
    #3
    macbook problems

    this might help you - I got this from a computer geek at a mac shoppe in san jose. maybe this can help your situation by resetting the smc

    give this a try:

    Shut down the computer.
    Disconnect the MagSafe power adapter from the computer, if it's connected.
    Remove the battery.
    Press and hold the power button for 5 seconds.
    Release the power button.
    Reconnect the battery and MagSafe power adapter.
    Press the power button to turn on the computer.
     
  4. jeebob2112 thread starter macrumors newbie

    Joined:
    Feb 16, 2012
    #4
    No luck with any of these, unfortunately. :confused:

    Just realized that even with the battery out, I can only use the computer for about 10 min or so without it crashing when the 2nd stick is in. Still no problems with just the one.
     

Share This Page