Ram still in use after parallels shut down

Discussion in 'Windows, Linux & Others on the Mac' started by Tom Foolery, Dec 24, 2008.

  1. Tom Foolery macrumors regular

    Joined:
    Oct 16, 2007
    Location:
    Toronto, Canada
    #1
    I just installed vista with parallels 4. i'm and running an 2.2 C2D MBP with 4GB Ram. i have had to restart parallels 2 or 3 times after i installed all the proper updates. however each time i restart it the ream doesn't change to free it stays and inactive or active. and each time i start parallels up again it takes up a little more Ram

    Right now i have only Safari, Itunes, Mail, and transmission running yet activity moniter says i only have 1.18GB free. this is not as much of a problem right no since i rarely use all 4GB but it was when i was running 2GB and I would still like to solve it

    thanks
     
  2. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #2
    hello,

    RAM has a very wierd way of working. when a program requests RAM the RAM will be marked as "active", when you quit a program the RAM that was used by that particular program will become "inactive" until another program requests it.

    i guess this is a kind of fault with all computer systems, not really a fault though.. i wouldnt worry about it, all the RAM is still available after it has been used and once the program has quit.. OSX just has a funny way of showing it..
     
  3. Tom Foolery thread starter macrumors regular

    Joined:
    Oct 16, 2007
    Location:
    Toronto, Canada
    #3
    thanks. that's exactly it. i read that on an apple page. i was worried that my new RAM was garbage
     

Share This Page