RAM test. What does this mean?

Discussion in 'Mac Basics and Help' started by 1800DOCTORB, Nov 7, 2005.

  1. 1800DOCTORB macrumors newbie

    Nov 5, 2005
    I've been experiencing lots of kernel panics for a while now, so I recently did some RAM tests to see if that was the problem. I ran Apple Hardware test looped 50x and got no errors, but then ran Memtest and after a while it came up with this result...

    "segmentation fault"

    Then I ran Rember to double check the results. Every time it ran it quit the test and said "Errors Found. Test Failed." I'll post the log from the test below. Does anyone know what this means? Is my RAM bad? And if its bad, why doesn't Apple Hardware Test find any issues?

    Memtest version 4.11 (32-bit)
    Copyright (C) 2004 Charles Cazabon
    Copyright (C) 2004, 2005 Tony Scaminaci (Macintosh port)
    Licensed under the GNU General Public License version 2 only

    MacOS X (Darwin) running in multiuser mode
    POSIX version 200112
    Pagesize is 4096
    Requested memory: 1790MB (1876951040 bytes)
    Available memory: 1827MB (1916567552 bytes)
    Allocated memory: 1790MB (1876951040 bytes) at local address 0x02008000
    Attempting memory lock... locked successfully
    Creating test buffers...
    Buffer A: 895MB (938475520 bytes) at local address 0x02008000
    Buffer B: 895MB (938475520 bytes) at local address 0x39f08000

    Running 3 test sequences...

    Test sequence 1 of 3:
    Stuck Address : setting 0testing 0setting 1testing 1setting 2testing 2setting 3testing 3setting 4testing 4setting 5testing 5setting 6testing 6setting 7testing 7setting 8testing 8setting 9testing 9setting 10testing 10setting 11testing 11setting 12testing 12setting 13testing 13setting 14testing 14setting 15testing 15 ok
    Random Value : \|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/- ok
    Compare XOR : ok
    FAILURE: 0x495d513b != 0xf52618b8 at offset 0x072f7ea0.
    Compare SUB : FAILURE: 0x36c8da45 != 0xbdaf7348 at offset 0x072f7ea0.
    Compare MUL : FAILURE: 0x00000001 != 0x00000004 at offset 0x072f7ea0.
    Compare DIV : Compare OR : ok
    Compare AND : ok
  2. yenko macrumors 6502a

    Aug 29, 2005
    Is this some how related to your other post, or do you have a different problem?
  3. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    I'm not familiar with the specific errors, but it basically sounds like you've either got a bad stick of RAM, or a motherboard issue that looks like bad RAM. If you're having problems, I'd try pulling out whichever stick was generating the errors (or if you can't tell, just go from one to the next) and see if it helps. If you've only got one stick, either go to Apple for warranty repair, or if it's out of warranty you can risk the cash on a new stick to see if that helps.

    If nothing fixes the issue, then it's probably a bad motherboard, which is an Apple-repair-only problem.

    Also, if a stick you bought is bad, you can probably get it replaced under warranty--almost every decent RAM maker has a lifetime warranty.

Share This Page