RAM upgrade being weird

Discussion in 'MacBook Pro' started by saintbenzie, Jun 5, 2012.

  1. saintbenzie macrumors newbie

    Joined:
    Jun 5, 2012
    #1
    Ok, so I have a Mid 2009 MBP 15". I have had the standard 4gb of RAM since I first had it and was looking to upgrade. I researched online and it looks like everyone says that my MBP would support 8gb. I purchased 8gb of Corsair Vengance 204pin memory and when I installed it and went to turn on my Mac the screen stayed black and started making three beeps. It kept doing this till I had to force it to shutdown. Then after freaking out I put the old 4gb of memory back in and it boots just fine. After this I try to use one of the new 4gb chips and one of the old 2gb chips and it boots up with 6gb of RAM. I tried both of the new RAM chips on the top and bottom slot mismatched with the older memory and they work every time which means they are both in working condition. They just won't boot when they are installed at the same time. Does anyone know what may be going on? It would be VERY appreciated.
     
  2. tarponbeach macrumors member

    Joined:
    Jan 24, 2012
    #2
    I had the same problem when I upgraded my 2009 MBP. Black screen, three beeps. I took the 2 memory boards out, and firmly re-inserted them. All good after that. Hope this helps.
     
  3. saintbenzie thread starter macrumors newbie

    Joined:
    Jun 5, 2012
    #3
    Is there any way you could point me to some sort of tutorial of how this could be done. I really don't want to screw it up. I'm not that much of a tech guy when it comes to the actual hardware.
     
  4. saintbenzie thread starter macrumors newbie

    Joined:
    Jun 5, 2012
    #5
    I have reinserted the new memory at least 10+ times and every time it still beeps. I might just try a different set of 8gb memory to see if for some reason there was some incompatibility for some reason.
     
  5. cookiesnfooty macrumors 6502

    cookiesnfooty

    Joined:
    Jul 1, 2009
    Location:
    Harrogate
    #6
    The info I found for you regarding compatibility:

    6GB (1x2GB/1x4GB)
    8GB (2x4GB) (Usable on newer Unibody systems)
     
  6. saintbenzie thread starter macrumors newbie

    Joined:
    Jun 5, 2012
    #7
    I have it all fixed. I bought new 8gb memory and it works no problem. It looks like the problem was incompatibility with the specific RAM I purchased. Thank you for all the advice.
     

Share This Page