RAM upgrade MBP resulted in continuous grey boot screen

Discussion in 'Mac Basics and Help' started by Slrunna, Jan 15, 2013.

  1. Slrunna, Jan 15, 2013
    Last edited: Jan 15, 2013

    Slrunna macrumors newbie

    Jan 15, 2013
    Hi all,

    I trust everyone had an enjoyable festive period.

    I have a 17" MacBook Pro the model is mid 2010 2.53ghz

    I run Photoshop, In design and Illustrator frequently and as a result I noticed a slowing down of my system.

    Decided to upgrade my ram, I bought 2 of the following Corsair 4GB DDR3 1066Mhz Mac Memory SO-DIMM Module CL7 1.5V to take it to its 8gb capacity. I believe that this should all be compatible.

    After installing what I believe is properly, the system does not launch. I get to the grey screen which shows the apple logo and nothing else.

    I am able to boot in safe mode, going into the system details shows that I have 8gb ram running no problem. I have verified disk permissions and then repaired them all is ok.

    After restarting in safe mode and booting in normal mode the same grey screen appears.

    I have reset the VRAM with no effect, the same error occurs.

    I have put the old ram in and it works fine in normal mode, no problems.

    Could someone please shed some light on what is going on and how to fix it.

    Thanks in advance.
  2. James Craner macrumors 68000

    James Craner

    Sep 13, 2002
    Bristol, UK
    Either the RAM is bad (it does happen) or it is not compatible. I generally use www.crucial.com to buy my 3rd Party Apple RAM as they have a compatibility checker for Macs. I would send the RAM back for a refund.
  3. -aggie- macrumors P6


    Jun 19, 2009
    Where bunnies are welcome.
    I'll second the advice to use Crucial. They're the most compatible non-Apple memory AFAIK.
  4. Slrunna thread starter macrumors newbie

    Jan 15, 2013
    This is what I thought may be the case, however I am not sure how I stand after opening and fitting the RAM into the laptop.

    As far as I am aware it is fully compatible.
  5. James Craner macrumors 68000

    James Craner

    Sep 13, 2002
    Bristol, UK
    Your only option is to speak to the supplier. Explain the situation. I would personally try and see if they will simply refund, but unless they explicitly said that it would work in your Mac they may just want to swap it out. At least try and get agreement up front that if they swap the memory, if it still does not work you can ask for a refund.

    I don't know were you live and what the consumer protection laws are were you are.
  6. SlCKB0Y macrumors 68040


    Feb 25, 2012
    Sydney, Australia
    Try this first:

    1. Try reseating the RAM.
    2. Test each stick individually in the MBP.

    Macs can tend to be fussy about the RAM they take, even when you match specs. It's usually only a few dollars more to get RAM certified for Mac anyways which means that the manufacturer has at least done some testing on Apple products.

    This looks like the RAM you want I think?
  7. Slrunna thread starter macrumors newbie

    Jan 15, 2013
    I have tried re-setting it in there, I knew that macs can be a bit funny about the RAM they have hence buying what I believed to be MAC tested ram, or so the site said.

    I have emailed them, so we will see if I can get a refund, guess I will be buying from Crucial as everyone seems to be telling me that is the best resolution.
  8. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    You're by no means the first one with RAM from Corsair with problems, there are plenty here on MR which seem to have the same problems, I don't see this with RAM from crucial.

    But, you could as a last resort reset the SMC and see if that works.

    Resetting the System Management Controller - Support - Apple
  9. Slrunna thread starter macrumors newbie

    Jan 15, 2013
    It seems that I have read that a lot since finding this problem Justperry.

    I thought about resetting the SMC but I think I will see what the store has to say first before doing that.

    Crucial it is I think.
  10. Matt51, May 23, 2013
    Last edited: May 23, 2013

    Matt51 macrumors newbie

    May 23, 2013
    Hi Slrunna,

    Did you fixed the problem ? I have the same issue on my Macbook Pro mid-2010.


Share This Page