ran fsck -y after reboot issue. what now?

Discussion in 'MacBook Pro' started by NoBob, Jul 24, 2007.

  1. NoBob macrumors member

    Joined:
    Jun 5, 2007
    #1
    Hi,

    I got up this morning and found that a white icon (looks like a white hard drive) "Seagate 4" had mysteriously appeared on my desktop. My other Seagate external HDs were showing up okay on the desktop. I tried ejecting them all, but couldn't. Apple Mail just kept bouncing in the dock when I tried to open it up. So I shut the OS down.

    On reboot, I got the chime and the spinning wheel thingy. Tried three or four times.

    Luckily I still have my PC and googled for what to do. Decided to go straight for fsck. Ran fsck -y twice. Got the green light.

    Fsck reported that there were problems with the block count, file match, file mach.sym (I think it was .sym), swapfile0, catalog hierarchy, and "volume bitmap needs minor repair."

    Is there anything I should do now? Apart from backing everything up!

    Thanks,
    NoBob.
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    You'll need an f.


    Code:
    /sbin/fsck -fy

    Obviously back everything up too. Hopefully this'll repair your errors though. :)
     

Share This Page