Ran Onyx, Stuck on grey screen

Discussion in 'OS X Yosemite (10.10)' started by qpid360, Nov 3, 2014.

  1. qpid360 macrumors 6502

    qpid360

    Joined:
    Apr 23, 2009
    Location:
    Pasadena, CA
    #1
    This blows. Downloaded the latest version of Onyx for Yosemite and ran it. After restarting, the progress bar gives up about halfway and I get stuck on the no progress icon/grey screen. Tried every solution on the web with no luck.

    Restoring via a two-week old TM backup, but I'm very upset about losing some important data. If you download the app, tread carefully.
     
  2. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #2
    what did you run? i've used onyx since forever (and currently, with 10.10); outside of the issue of not being able (yet) to check smart status, seems to work as well as always...

    worth keeping an eye on tho...
     
  3. qpid360 thread starter macrumors 6502

    qpid360

    Joined:
    Apr 23, 2009
    Location:
    Pasadena, CA
    #3
    I just ran th default maintenance options.

    Aaa and restore from backup didn't fix it. Looks like I'll be reinstalling Yosemite.
     
  4. definitive macrumors 68000

    definitive

    Joined:
    Aug 4, 2008
    #4
    Onyx is one of those apps that you shouldn't run unless you know what you're doing. Apps like Disk Doctor and CCleaner are more newbie-friendly for cleaning cache/log files off of your system.
     
  5. qpid360 thread starter macrumors 6502

    qpid360

    Joined:
    Apr 23, 2009
    Location:
    Pasadena, CA
    #5
    Been running Onyx for years and various iterations of OSX. This is the first time I've encountered this issue. For all I know, it could've been a complete fluke and something else triggered the issue. I'm just thinking Onyx was the problem because it was the last thing I ran before restarting.
     
  6. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #6

    Using Trim Enabler for your non-Apple SSD?

    See more info's at http://www.titanium.free.fr
     
  7. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #7
    It sounds like this is the problem. Recovery instructions are here.
     
  8. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #8

    Indeed! That's the link I forgot to mention in my reply, THNX! ;)
     
  9. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #9
    OnyX 2.9.4 -> Warning added for Trim Enabler!

    In the newest version a warning is added when using OnyX icw Trim Enabler!

    [​IMG]
     
  10. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #10
    As an alternative, you might consider the app called "Yasu".

    I don't think it does -everything- that OnYx can do, but it does quite a bit...
     
  11. Jigga macrumors 6502

    Joined:
    Jun 11, 2009
    #11
    Yasu is no longer being developed: http://yasuapp.net/
     
  12. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #12
    [[ Yasu is no longer being developed: http://yasuapp.net/ ]]

    Even so, still seems to be working in Yosemite...
     

Share This Page