Random Alltel Question

Discussion in 'Community Discussion' started by tracetritt, Dec 15, 2007.

  1. tracetritt macrumors member

    Joined:
    Jun 10, 2007
    Location:
    Northwestern Wisconsin, USA
    #1
    This is the very first time that I have ever encountered this so I maybe slightly ignorant to it but still, I cannot believe it!

    Ok, so I went to my account online at the alltel website. www.alltel.com/myaccount. I logged in and went to change some of my features. Lo and behold, it says that I have to have microsoft IE 6 or higher. What kind of bull is that? What is so difficult that can ONLY be done in IE? It most certainly cannot be that difficult. Anyways, thanks for reading this mini rant. Have a nice night!

    Tyler
     
  2. DakotaGuy macrumors 68040

    DakotaGuy

    Joined:
    Jan 14, 2002
    Location:
    South Dakota, USA
    #2
    Unless they just changed something I have never had an issue with using Safari on the Alltel account site. I guess I usually just use the bill pay feature and a few other things like the call log, etc. I'll have to log in to see what happens when I get some time. I guess if I have to pull out the Lenovo to use the site I can, but what a pain in the rear that will be.
     
  3. tracetritt thread starter macrumors member

    Joined:
    Jun 10, 2007
    Location:
    Northwestern Wisconsin, USA
    #3
    I tried it with Safari as well as Firefox. Everything works except the add/change plan features. I can always boot up into boot camp too..but again, who wants to restart to just change a few things on an account?

    I feel like writing a nasty letter to them on web standards. :rolleyes:..with my luck it probably has nothing to do them but oh well.
     
  4. SkyBell macrumors 604

    SkyBell

    Joined:
    Sep 7, 2006
    Location:
    Texas, unfortunately.
    #4
    They could at least support firefox. It isn't that hard to do.
     

Share This Page