Random Apple ID password prompts

Discussion in 'iOS 8' started by zorinlynx, Feb 9, 2015.

  1. zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #1
    Anyone get these from time to time? You wake up the iPad or iPhone and get asked for your password at the home screen. Most of the time I actually need to use the device immediately and don't have time for that nonsense so I hit cancel. A few times I've entered the password, which seems to make it stop doing that for a while, but it inevitably asks again at some point.

    It would be nice if iOS would tell you WHY it's asking you for your password. People who aren't familiar with the iOS security model might rightfully assume it's an app trying to steal your Apple ID password!
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    Are you using any capital letters in your iCloud username/email when you set it up on your device?
     
  3. madsci954 macrumors 68030

    Joined:
    Oct 14, 2011
    Location:
    Ohio
    #3
    This was happening to me at one point, and it always happened on a reboot. Turns out the iTunes store app was trying to download a song I didn't have anymore. I would tap to download but it would just disappear, only to turn back up on the next reboot (which happens often as I'm plagued with random reboots)

    I tried numerous steps to get rid of it, including signing in and out of my Apple ID, reboots mixed in, trying to remove the song from iTunes on my Mac, and nothing worked. I ended up restoring my phone and setting up as new and the prompts went away.
     
  4. apple.snapple macrumors regular

    Joined:
    Jun 3, 2014
    #4
    I get a password pop up, seemingly, a dozen times when I factory reset my phone. I just keep putting it in until it goes away. I'll put it to sleep, then on the next wake up I'll have to put it in a couple more times. Another sleep, maybe one more password. After that, it's quiet.

    I wish Apple would tell you WHY it's needing the password.
     
  5. crashoverride77 macrumors 65816

    Joined:
    Jan 27, 2014
    #5
    Had that as well with 8.1.2, it either prompted for icloud or Apple id password. Since 8.1.3 this has stopped for me not sure why tho.
     

Share This Page