Random Apps Crashing iPhone to Safe Mode (warning: NoAccessorySplash)

Discussion in 'Jailbreaks and iOS Hacks' started by mrat93, Aug 19, 2010.

  1. mrat93 macrumors 65816


    Dec 30, 2006
    Last night when I was out, I tried going to Cydia. It loaded for a few seconds, then springboard crashed. I rebooted, and it happened again.

    The same thing happened when I tried going to the App Store. Later that night, Mail and Safari had a similar issue. After several crashes, my iPhone (4) hung at the Apple logo for a while, so I did a hard reset. When it turned on, those apps were fine. No crashes whatsoever.

    More recently, random third party apps (RunPee and DoodleBuddy) are crashing the springboard.

    The only thing I installed recently before this issue was an update to NoAccessorySplash iOS4 1.2-2. I just uninstalled it, and as far as I've seen, no apps have crashed the springboard yet.

    Just figured I'd post this in case anybody else has a similar issue.
  2. xamp macrumors newbie

    Nov 18, 2006
    Thank you for posting this!! Our two phones started crashing last night and I couldn't figure out what was causing it. I started uninstalling apps (Calendar Pro, Music Controls, 3G Unrestrictor) but totally forgot about the update to NoAccessorySpash last night.

    I hope they push a fix soon, I really like that mod.

  3. boshii macrumors 68040


    Jul 6, 2008
    Atlanta, GA
    i installed noaccessorysplash yesterday but haven't experienced what you guys have experienced.
  4. JackNorris macrumors newbie

    Oct 23, 2009
    NoAccessorySplash iOS4 1.2-2 has a crash issue that has now been fixed in 1.3-1 :)
  5. mrat93 thread starter macrumors 65816


    Dec 30, 2006
    The changelog says that it fixes some sort of SMS bug. It never had to do with SMS for me, but I'll give it a shot.
  6. kAoTiX macrumors 6502


    Oct 14, 2008
    Midlands, UK
    I didn't have random app crashes with the previous version but it was messing up the ipod out to my car head unit.
    I e-mailed Jack (author) and he promptly replied and there was an update in Cydia. It seems to have since fixed the issues I was having.

    I'm grateful to Jack for being very quick at getting back to me and helping me with the problem. If only all devs were like this :D

Share This Page