Random Error

Discussion in 'iOS Programming' started by Wellington2k, Nov 22, 2011.

  1. Wellington2k macrumors regular

    Joined:
    Jun 4, 2011
    #1
    I was minding my old coding business, when all of a sudden (like seriously all of a sudden) when I run my app I get this error:

    Code:
    2011-11-22 18:11:17.386 Awexome[651:12503] Error loading /System/Library/Extensions/AudioIPCDriver.kext/Contents/Resources/AudioIPCPlugIn.bundle/Contents/MacOS/AudioIPCPlugIn:  dlopen(/System/Library/Extensions/AudioIPCDriver.kext/Contents/Resources/AudioIPCPlugIn.bundle/Contents/MacOS/AudioIPCPlugIn, 262): Symbol not found: ___CFObjCIsCollectable
      Referenced from: /System/Library/Frameworks/Security.framework/Versions/A/Security
      Expected in: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.0.sdk/System/Library/Frameworks/CoreFoundation.framework/CoreFoundation
     in /System/Library/Frameworks/Security.framework/Versions/A/Security
    2011-11-22 18:11:17.395 Awexome[651:12503] Error loading /System/Library/Extensions/AudioIPCDriver.kext/Contents/Resources/AudioIPCPlugIn.bundle/Contents/MacOS/AudioIPCPlugIn:  dlopen(/System/Library/Extensions/AudioIPCDriver.kext/Contents/Resources/AudioIPCPlugIn.bundle/Contents/MacOS/AudioIPCPlugIn, 262): Symbol not found: ___CFObjCIsCollectable
      Referenced from: /System/Library/Frameworks/Security.framework/Versions/A/Security
      Expected in: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.0.sdk/System/Library/Frameworks/CoreFoundation.framework/CoreFoundation
     in /System/Library/Frameworks/Security.framework/Versions/A/Security
    2011-11-22 18:11:18.225 Awexome[651:12503] Error loading /System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHALPlugIn.bundle/Contents/MacOS/AppleHDAHALPlugIn:  dlopen(/System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHALPlugIn.bundle/Contents/MacOS/AppleHDAHALPlugIn, 262): Symbol not found: ___CFObjCIsCollectable
      Referenced from: /System/Library/Frameworks/Security.framework/Versions/A/Security
      Expected in: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.0.sdk/System/Library/Frameworks/CoreFoundation.framework/CoreFoundation
     in /System/Library/Frameworks/Security.framework/Versions/A/Security
    2011-11-22 18:11:18.231 Awexome[651:12503] Error loading /System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHALPlugIn.bundle/Contents/MacOS/AppleHDAHALPlugIn:  dlopen(/System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHALPlugIn.bundle/Contents/MacOS/AppleHDAHALPlugIn, 262): Symbol not found: ___CFObjCIsCollectable
      Referenced from: /System/Library/Frameworks/Security.framework/Versions/A/Security
      Expected in: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.0.sdk/System/Library/Frameworks/CoreFoundation.framework/CoreFoundation
     in /System/Library/Frameworks/Security.framework/Versions/A/Security
    2011-11-22 18:11:18.255 Awexome[651:12503] Error loading /System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHALPlugIn.bundle/Contents/MacOS/AppleHDAHALPlugIn:  dlopen(/System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHALPlugIn.bundle/Contents/MacOS/AppleHDAHALPlugIn, 262): Symbol not found: ___CFObjCIsCollectable
      Referenced from: /System/Library/Frameworks/Security.framework/Versions/A/Security
      Expected in: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.0.sdk/System/Library/Frameworks/CoreFoundation.framework/CoreFoundation
     in /System/Library/Frameworks/Security.framework/Versions/A/Security
    2011-11-22 18:11:18.262 Awexome[651:12503] Error loading /System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHALPlugIn.bundle/Contents/MacOS/AppleHDAHALPlugIn:  dlopen(/System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHALPlugIn.bundle/Contents/MacOS/AppleHDAHALPlugIn, 262): Symbol not found: ___CFObjCIsCollectable
      Referenced from: /System/Library/Frameworks/Security.framework/Versions/A/Security
      Expected in: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.0.sdk/System/Library/Frameworks/CoreFoundation.framework/CoreFoundation
     in /System/Library/Frameworks/Security.framework/Versions/A/Security
    2011-11-22 18:11:18.273 Awexome[651:12503] Error loading /System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHALPlugIn.bundle/Contents/MacOS/AppleHDAHALPlugIn:  dlopen(/System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHALPlugIn.bundle/Contents/MacOS/AppleHDAHALPlugIn, 262): Symbol not found: ___CFObjCIsCollectable
      Referenced from: /System/Library/Frameworks/Security.framework/Versions/A/Security
      Expected in: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.0.sdk/System/Library/Frameworks/CoreFoundation.framework/CoreFoundation
     in /System/Library/Frameworks/Security.framework/Versions/A/Security
    2011-11-22 18:11:18.280 Awexome[651:12503] Error loading /System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHALPlugIn.bundle/Contents/MacOS/AppleHDAHALPlugIn:  dlopen(/System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHALPlugIn.bundle/Contents/MacOS/AppleHDAHALPlugIn, 262): Symbol not found: ___CFObjCIsCollectable
      Referenced from: /System/Library/Frameworks/Security.framework/Versions/A/Security
      Expected in: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.0.sdk/System/Library/Frameworks/CoreFoundation.framework/CoreFoundation
     in /System/Library/Frameworks/Security.framework/Versions/A/Security
    2011-11-22 18:11:18.324 Awexome[651:12503] Error '!dat' trying to set the (null) audio devices' sample rate
    2011-11-22 18:11:18.387 Awexome[651:12503] Unable to set default stereo pair on aggregate: 'who?'
    So I searched and searched, I added the frameworks in the error, still nothing.

    All I know is it has something to do with me sound playing code.

    Code:
        NSString *path = [[NSBundle mainBundle] pathForResource:@"Ingame" ofType:@"wav"];  
        TheAudio=[[AVAudioPlayer alloc] initWithContentsOfURL:[NSURL fileURLWithPath:path] error:NULL];  
        TheAudio.delegate = self;  
        [TheAudio play]; 
        TheAudio.numberOfLoops = -1;
    So as a test I went to another app with the same code, that I hadn't changed in weeks, and ran it.

    Same error.

    I tried rebooting, but still it remains.

    I need help.

    Thanks!
     
  2. Wellington2k thread starter macrumors regular

    Joined:
    Jun 4, 2011
    #2
    Got it.

    I had to unplug and replug the headphone jack.

    Just in case anyone needs to know. :)
     

Share This Page