random extra character when typing

Discussion in 'MacBook' started by podopie, Mar 8, 2009.

  1. podopie macrumors newbie

    Joined:
    Nov 13, 2008
    #1
    Difficult to explain. It's not actually there when I type, but it appears in messages and what not after they've been sent off. If I read in Firefox I see it on facebook sometimes (Safari doesn't recognize the character so it won't display it). Also happens when I type it a web address, I get a %f or something in front of the whole address!

    I don't understand the deal. I have a 2.0ghz early 07 macbook (i believe). It mostly happens when erasing what I write, and I usually need to include one extra backspace to get this "invisible" character.

    Thanks guys!

    EDIT: Picture included is what Firefox encodes the character as.
     

    Attached Files:

  2. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #2
    Interesting, it almost looks like an emoticon, but I'm not sure...:eek:
     
  3. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #3
    Have you tried repairing permissions using Disk Utility? I would try that and see if it works.
     
  4. podopie thread starter macrumors newbie

    Joined:
    Nov 13, 2008
    #4
    Nothing from repairing permissions. Has no one else really experience this before?
     
  5. fourtyoneantz macrumors member

    Joined:
    Feb 11, 2009
    #5
    that's...bizarre. haha. call up your local apple store/authorized dealer or mac tech support and see what they say.

    if you've already done this, what was their advice?
     

Share This Page