Random freezing/crashing on MBP 2011

Discussion in 'MacBook Pro' started by Nocky24, Jul 19, 2011.

  1. Nocky24, Jul 19, 2011
    Last edited: Jul 19, 2011

    Nocky24 macrumors member

    Joined:
    Jun 26, 2011
    #1
    It's usually when I'm doing some light multi-tasking, and just running a couple of applications at once. For example today I was running utorrent and an .avi file in quicktime and it started freezing intermittently. I've noticed that when iTunes or quicktime is open, it'll regularly freeze if I try to do anything else or open anything 3D orientated.

    I've noticed in the console I don't get any obvious crash errors as such, but npvhash 4095 tends to appear after a hard freeze. I've also had some modem errors claiming it isn't compatible as it's 64 bit.

    So far I've:

    -Taken it to Apple and their overnight testing/diagnostics have come back clear.
    -Reset PRAM
    -Reset SMC
    -Ran the Apple Hardware Test (extended)- all clear
    -Repaired Permissions
    -Verified OS Disk Drive
    -Erased and reinstalled OSX a number of times
    -Tried a different HDD
    -Verified Fonts (something I came accross when searching npvhash 4095 error)

    Overall, nothing has helped so I'm in the process of RMA'ing unless anyone here can come up with the solution :p

    Any ideas will be greatly appreciated.
     
  2. pcomac macrumors regular

    Joined:
    Jun 22, 2011
    #2
    virus or malware? i know there are a lot of people who swear that macs dont get them but....... its better to be safe and get an antivirus anyways.... especially if you are a guy. i hope you dont watch porn... but really you should get it if you are one of those guys :)
     
  3. Nocky24 thread starter macrumors member

    Joined:
    Jun 26, 2011
    #3
    Cheers for your response :) I've also erased and reinstalled OSX a number of times and it still happens so I'm not sure if it's a virus issue.
     
  4. getz76 macrumors 6502a

    getz76

    Joined:
    Jun 15, 2009
    Location:
    Hell, AL
    #4
    Looks like you have done extensive troubleshooting. The only other thing I can think of is to swap the memory. Any chance you have some spares lying around? If not, try taking out one module and seeing if you can recreate the problem, then swap the modules.

    The reason I say this is because software-based memory diagnostics are notoriously unreliable.
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    Antivirus is not necessary to protect Mac OS X from malware. No viruses exist in the wild that can run on Mac OS X, and there never have been any, since it was released 10 years ago. The handful of trojans that exist can be easily avoided with some basic education, common sense and care in what software you install:
    You can't get malware on Mac OS X simply by visiting porn sites, or any sites. The only Mac OS X malware that exists requires you to actively install it.
    It's definitely not a virus issue. Do you have Parallels installed? Also, are you booting in 32 or 64 bit mode?

    Launch Activity Monitor and change "My Processes" at the top to "All Processes". Then look to see what may be consuming system resources.
     
  6. Nocky24 thread starter macrumors member

    Joined:
    Jun 26, 2011
    #6
    Unfortunately I don't have any modules I can swap to test, however I may give your other suggestion a go and try one module at a time.

    I'll check the activity monitor when I get back from work then and report back :)

    Also I don't have Parallels installed, its a fresh install consisting of utorrent, WoW and Steam. Also I believe I'm booting in 64 bit mode, but not 100% anyway I can check?

    If it's any help, I had a standard res 15" 2011 MBP (same specs) for a short time, which didn't have any of these issues I'm currently having.
     
  7. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #7
  8. Nocky24 thread starter macrumors member

    Joined:
    Jun 26, 2011
    #8
    Thanks for that, it's 64 bit. As I said I ran another MBP 2011 15" for a short period, which experienced the same usage conditions as this one, however I had none of these problems. It seems like no amount of testing will solve it :( I'm reluctant to take it to the Apple Store again as there's no guarantee I can replicate the issue as it's very hit and miss, hence the RMA.
     
  9. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #9
    Try running in 32 bit mode.
     
  10. Nocky24 thread starter macrumors member

    Joined:
    Jun 26, 2011
    #10
    Thanks I'll try that. Any suggestions as to what to do if it is a problem with 64 bit?
     

Share This Page