Random Missing Contacts

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Mobster1983, Sep 30, 2012.

  1. Mobster1983 macrumors 6502

    Joined:
    Sep 8, 2011
    #1
    My girlfriend has been having an issue with missing contacts on here iPhone 4S for a while. She be looking for a number and the contact that was on there before is now gone. This is not happening to every contact, just some of them.

    This issue happened on iOS 5 and continues to happen on iOS 6. She uses Microsolft exchange server for work and has contacts from there, as well as when she adds contacts on the phone itself.

    Is there any way to stop her phone from deleting random contacts?
     
  2. lyndeam macrumors member

    Joined:
    Jan 6, 2009
    #2
    I am experiencing the same thing today. I got the iPhone5 with iOS6 the day after it came out. I restored the phone from my latest iPhone 4 backup (not updated to iOS6) and everything has been fine. Today I noticed that I received text from numbers not in my contact list (so a name was not associated) to then realize that these were from people I know, have a lengthy text history with already and actually texted yesterday. So these contacts were in my contact list just yesterday. I've been on iOS6 since I received my phone launch day so this isn't the result of an update. I can't recall changing any settings in the last day or so. I don't want to have to restore from backup. Any suggestions on what the issue could be?
     
  3. lyndeam macrumors member

    Joined:
    Jan 6, 2009
    #3
    I figured my issue out, which may be the same as your girlfriends. I also have an exchange server for work setup on my phone. Today, within outlook, I deleted a bunch of mail contacts - many of them I remember being those that are missing from my phone now (in retrospect I remember wondering to myself how these contacts ended up in my outlook contact list). I'm hoping the way to correct this for the future is to set iCloud as my default contact account (I originally had my work exchange server selected) SETTINGS-MAIL,CONTACT,CALENDERS scroll down to the CONTACTS section and change DEFAULT ACCOUNT to iCloud...
    Hopefully :)
     

Share This Page