iPhone Random reboots?

Discussion in 'Jailbreaks and iOS Hacks' started by vols, May 1, 2014.

  1. vols macrumors regular

    Joined:
    Jun 25, 2013
    #1
    Using an i5 with 7.0.6

    The last day or so, my battery has been draining and my phone would just randomly reboot. The screen would change colors and a white vertical bar would appear and then the apple logo will follow. The apple logo will then turn to a different shade of color and reboot again. I have to hard boot it just to get it to turn off, but have to wait a good 10-15 mins to turn it back on, or I would be stuck in the boot-loop. All the tweaks I've recently added have been removed, but it still happens.

    I would hate to lose my jailbreak, but if resetting it to factory is the only fix, then I'll just swallow the pill...Thanks for any guidance..
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    if you're at the point you're willing to resetting it to factory, then i would suggest uninstalling cydiasubstrate (which will uninstall all your tweaks) and then reinstall the ones that you know for sure that aren't causing the problem

    appinfo from cydia can help you export a list of your cydia packages
     
  3. vols, May 2, 2014
    Last edited: May 2, 2014

    vols thread starter macrumors regular

    Joined:
    Jun 25, 2013
    #3
    I thought I was in the clear. I removed a few apps and all day today, no reboots. Now it randomly brings a greyish dark shade and my phone reboots.i feel like it randomly reboots when my battery hits around 20%. I thought it was an app, but after shutting down my phone and powering back up (nothing running) it did it again. This is also after removing cydiasubstrate...so no tweaks are installed at this time.

    I really don't want to lose my jailbreak...but gotta do what I gotta do..

    Anything else I could try before starting from scratch? :(

    Edit: oddly enough...my home screen looks like tweaks were removed, but I still have f.lux and other tweaks (iFile, iCleaner) installed in one of my folders. But opening Cydia and going into installed packages...no tweaks are shown...

    I'm puzzled haha
     
  4. vols thread starter macrumors regular

    Joined:
    Jun 25, 2013
    #4
    Trying iLex Rat...used option 12 to cleanup my entire iPhone from all Cydia tweaks, etc. Rat started flashing all of the directories it was cleaning...stop randomly and restarted as it always has. Rat normally asks to restart after it cleans up...but now I'm in a boot-loop...

    Long live my jb? :(
     
  5. aPple nErd macrumors 68030

    aPple nErd

    Joined:
    Feb 12, 2012
    Location:
    Jailbreaks/IOS Hacks
    #5
    you could try running evasion again as a last option. if that doesn't fix it, you have to restore
     
  6. vols thread starter macrumors regular

    Joined:
    Jun 25, 2013
    #6
    I tried that last week. Seemed to work for a few days and started back up again. Really hate that this soldier has fallen...

    To the "Is there going to be a jb for 7.1?" bandwagon I go...:confused:

    Edit: And there is the Recover Mode screen...appearing randomly.
     
  7. vols thread starter macrumors regular

    Joined:
    Jun 25, 2013
    #7
    Now I'm getting errors 9 and 21 when trying to restore? Can someone assist? Not sure how my iPhone went from working great to nothing...
     
  8. Syndicate0017 macrumors 6502

    Joined:
    May 3, 2013
    #8

    Check your hosts file
     
  9. aPple nErd macrumors 68030

    aPple nErd

    Joined:
    Feb 12, 2012
    Location:
    Jailbreaks/IOS Hacks
  10. vols thread starter macrumors regular

    Joined:
    Jun 25, 2013
    #10
    I ended up using a different USB connection on my Air and it finally started to restore.

    Any idea how I can prevent this in the future?
     

Share This Page