Random restarting with 2009 iMac

Discussion in 'iMac' started by clownbaby, Nov 12, 2014.

  1. clownbaby macrumors member

    Joined:
    Jan 16, 2009
    #1
    Hello all,

    My iMac will randomly restart itself with no forewarning. It's not at set times nor is it "consistent" so to speak, though it does happen 5-7 times a week. It will simply restart and then reboot with the message that I restarted because of a problem. I tried googling and using the apple fixes but nothing has worked. Any ideas?
     

    Attached Files:

  2. dasmin19 macrumors newbie

    Joined:
    Jun 27, 2014
    #2
    I had Yosemite installed for a week. Then Safari started closing and my mac restarted. Then I got back on, and tried to open Firefox; it crashed, then imac restarted. On Monday of last week, computer restarted, and won't come back on for me. So now, if I power it on, it goes half way with bar. Then shuts down. I have a late 2009 imac.

    I screwed up and never made a back on my imac. So the only thing I believe; i can do, is load Yosemite on external drive. And try to boot in that way.

    So good luck.:)
     
  3. clownbaby thread starter macrumors member

    Joined:
    Jan 16, 2009
    #3
    Unfortunately I've had the issue since before Yosemite. I'd say it's been going on for about a year now. Not sure if my hard drive is failing or something else is going on.
     
  4. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #4
    I've had the same problem with my Mid-2009 MacBook Pro. It was bad RAM that the previous owner upgraded in (it was 8GB). Do a test with Apple Hardware Test and/or Memtest86.

    Apple Hardware Test: http://support.apple.com/en-us/HT201257
    Memtest86: http://www.memtest86.com/

    Right now I am sharing the 2x2GB (4GB) RAM between my 2009 iMac and 2009 MacBook Pro until i buy more RAM. :\
     
  5. dasmin19, Nov 12, 2014
    Last edited: Nov 12, 2014

    dasmin19 macrumors newbie

    Joined:
    Jun 27, 2014
    #5
    Exactly, I think I was the first time iMac purchaser, who had an issue from the start. lol. The first week I had it, the fan would start blowing and never turn off, unless I restarted it. But I got pass that. But with this new problem like the original poster. I think my hard drive is jacked up. I ran the /sbin/fsck -fy, it tells me "Invalid leaf record count(It should be 5439 instead of 5433). Rebuilding catalog B-tree. Disk full error. The volume Macintosh HD could not be repaired.
     

Share This Page