Random restarts in 13" 2015 MBP

Discussion in 'MacBook Pro' started by DeniK, Sep 29, 2016.

  1. DeniK macrumors newbie

    Joined:
    Sep 29, 2016
    #1
    I updated to Sierra a few days ago, and since then, my MBP had been randomly restarting. The Activity Monitor shows high CPU/Memory usage for kernel task and windows server, and the console has numerous logs relating to com.Apple.Webkit (with suffixes of memory_resource, wakeups_resource, and cpu_resource). I've reset the SMC & PRAM with no change in behavior.

    I ran EtreCheck this morning right after boot up with the following results:

    EtreCheck version: 3.0.6 (315)

    Report generated 2016-09-29 08:25:11

    Download EtreCheck from https://etrecheck.com

    Runtime 1:49

    Performance: Excellent



    Click the [Support] links for help with non-Apple products.

    Click the [Details] links for more information about that line.



    Problem: Computer is restarting



    Hardware Information:

    MacBook Pro (Retina, 13-inch, Early 2015)

    [Technical Specifications] - [User Guide] - [Warranty & Service]

    MacBook Pro - model: MacBookPro12,1

    1 2.7 GHz Intel Core i5 CPU: 2-core

    8 GB RAM Not upgradeable

    BANK 0/DIMM0

    4 GB DDR3 1867 MHz ok

    BANK 1/DIMM0

    4 GB DDR3 1867 MHz ok

    Bluetooth: Good - Handoff/Airdrop2 supported

    Wireless: en0: 802.11 a/b/g/n/ac

    Battery: Health = Normal - Cycle count = 187


    Video Information:

    Intel Iris Graphics 6100

    Color LCD 2560 x 1600


    System Software:

    macOS Sierra 10.12 (16A323) - Time since boot: less than an hour


    Disk Information:

    APPLE SSD SM0128G disk0 : (121.33 GB) (Solid State - TRIM: Yes)

    EFI (disk0s1) <not mounted> : 210 MB

    Recovery HD (disk0s3) <not mounted> [Recovery]: 650 MB

    Macintosh HD (disk1) / [Startup]: 120.11 GB (61.42 GB free)

    Core Storage: disk0s2 120.47 GB Online


    USB Information:

    Apple Card Reader

    Broadcom Corp. Bluetooth USB Host Controller


    Thunderbolt Information:

    Apple Inc. thunderbolt_bus


    Gatekeeper:

    Mac App Store and identified developers


    System Launch Agents:

    [not loaded] 7 Apple tasks

    [loaded] 166 Apple tasks

    [running] 98 Apple tasks


    System Launch Daemons:

    [not loaded] 38 Apple tasks

    [loaded] 161 Apple tasks

    [running] 104 Apple tasks


    Launch Agents:

    [failed] com.adobe.ARMDCHelper.cc24aef4a1b90ed56a725c38014c95072f92651fb65e1bf9c8e43c37a23d420d.plist (2016-07-13) [Support]


    Launch Daemons:

    [loaded] com.adobe.ARMDC.Communicator.plist (2016-07-13) [Support]

    [loaded] com.adobe.ARMDC.SMJobBlessHelper.plist (2016-07-13) [Support]

    [loaded] com.microsoft.autoupdate.helpertool.plist (2016-08-03) [Support]

    [loaded] com.microsoft.office.licensingV2.helper.plist (2016-02-12) [Support]


    User Launch Agents:

    [loaded] com.google.keystone.agent.plist (2016-07-11) [Support]

    [running] com.spotify.webhelper.plist (2016-07-26) [Support]


    Internet Plug-ins:

    AdobePDFViewerNPAPI: 15.017.20053 - SDK 10.11 (2016-08-02) [Support]

    NP_2020Player_IKEA: 5.0.94.1 - SDK 10.6 (2012-09-28) [Support]

    QuickTime Plugin: 7.7.3 (2016-09-13)

    AdobePDFViewer: 15.017.20053 - SDK 10.11 (2016-08-02) [Support]



    Safari Extensions:

    1Password - AgileBits - https://agilebits.com/onepassword (2016-09-28)

    Adblock Plus - Eyeo GmbH - https://adblockplus.org/ (2016-09-28)


    3rd Party Preference Panes:

    None


    Time Machine:

    Skip System Files: NO

    Mobile backups: OFF

    Auto backup: YES

    Volumes being backed up:

    Macintosh HD: Disk size: 120.11 GB Disk used: 58.69 GB

    Destinations:

    Time Machine [Network]

    Total size: 1.96 TB

    Total number of backups: 59

    Oldest backup: 3/14/16, 12:21 PM

    Last backup: 9/29/16, 8:20 AM

    Size of backup disk: Excellent

    Backup size 1.96 TB > (Disk size 120.11 GB X 3)


    Top Processes by CPU:

    5% kernel_task

    4% fontd

    3% WindowServer

    2% Safari

    0% hidd


    Top Processes by Memory:

    762 MB com.apple.WebKit.WebContent(8)

    695 MB kernel_task

    401 MB Safari

    303 MB Console

    229 MB softwareupdated


    Virtual Memory Information:

    1.56 GB Free RAM

    6.44 GB Used RAM (1.79 GB Cached)

    0 B Swap Used


    Diagnostics Information:

    Sep 29, 2016, 07:58:39 AM Self test - passed

    Sep 28, 2016, 10:54:27 AM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2016-09-28-105427_[redacted].cpu_resource.diag [Details]

    /System/Library/Frameworks/WebKit.framework/Versions/A/XPCServices/com.apple.WebKit.Plugin.64.xpc/Contents/MacOS/com.apple.WebKit.Plugin.64

    Sep 28, 2016, 10:12:01 AM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2016-09-28-101201_[redacted].cpu_resource.diag [Details]

    Sep 28, 2016, 09:55:57 AM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2016-09-28-095557_[redacted].cpu_resource.diag [Details]

    Sep 27, 2016, 08:29:54 PM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2016-09-27-202954_[redacted].cpu_resource.diag [Details]

    Sep 27, 2016, 08:17:03 PM ~/Library/Logs/DiagnosticReports/Activity Monitor_2016-09-27-201703_[redacted].crash

    com.apple.ActivityMonitor - /Applications/Utilities/Activity Monitor.app/Contents/MacOS/Activity Monitor

    Sep 27, 2016, 07:55:39 PM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2016-09-27-195539_[redacted].cpu_resource.diag [Details]

    Sep 27, 2016, 03:10:40 PM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2016-09-27-151040_[redacted].cpu_resource.diag [Details]

    Sep 27, 2016, 02:01:44 PM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2016-09-27-140144_[redacted].cpu_resource.diag [Details]

    Sep 27, 2016, 01:34:22 PM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2016-09-27-133422_[redacted].cpu_resource.diag [Details]

    Sep 27, 2016, 11:56:58 AM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2016-09-27-115658_[redacted].cpu_resource.diag [Details]

    Sep 27, 2016, 08:23:25 AM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2016-09-27-082325_[redacted].cpu_resource.diag [Details]

    Sep 26, 2016, 10:54:33 AM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2016-09-26-105433_[redacted].cpu_resource.diag [Details]

    Sep 26, 2016, 10:17:05 AM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2016-09-26-101705_[redacted].cpu_resource.diag [Details]

    Sep 26, 2016, 09:55:13 AM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2016-09-26-095513_[redacted].cpu_resource.diag [Details]

    Sep 26, 2016, 08:45:55 AM /Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2016-09-26-084555_[redacted].cpu_resource.diag [Details]



    And the details from the most recent log:


    Date/Time: 2016-09-28 10:51:56 -0500
    OS Version: Mac OS X 10.12 (Build 16A323)
    Architecture: x86_64
    Report Version: 19

    Command: com.apple.WebKit.Plugin.64
    Path: /System/Library/Frameworks/WebKit.framework/Versions/A/XPCServices/com.apple.WebKit.Plugin.64.xpc/Contents/MacOS/com.apple.WebKit.Plugin.64
    Version: 12602 (12602.1.50.0.10)
    Build Version: 1
    Project Name: WebKit2
    Source Version: 7602001050000010
    Parent: launchd [1]
    Responsible: Safari [283]
    PID: 1183

    Event: cpu usage
    CPU: 90s cpu time over 150 seconds (60% cpu average), exceeding limit of 50% cpu over 180 seconds
    Duration: 149.95s
    Steps: 233

    Hardware model: MacBookPro12,1
    Active cpus: 4



    Any ideas on what is causing this issue & what my next step should be?

    Thanks!

    Denise
     
  2. jerryk macrumors 68030

    Joined:
    Nov 3, 2011
    Location:
    SF Bay Area
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    Good on your for posting the Etrecheck report. Very helpful.

    It sounds like you have a third party app or utility running that is not compatible with Sierra, not we just need to figure out what it is.

    First thing I would try is to disable all these plugins. Go to this preference pane in Safari and uncheck the box at the bottom like mine is. If that fixes it, start removing those plugins to figure out which one it is.

    Screen Shot 2016-09-29 at 9.31.24 AM.png

    Next I would look at these launch items. They will be in one of these folders. There is no easy way to figure out which one it is. You just have to start removing them and rebooting, then testing. I would start with Spotify and all the Adobe items.

    Code:
    ~/Library/LaunchAgents (~ is your users folder)
    /Library/LaunchAgents
    /Library/LaunchDaemons
     
  4. DeniK thread starter macrumors newbie

    Joined:
    Sep 29, 2016
    #4
    Thanks for the help! I've changed the plug in settings, and removed the launch items, and unfortunately, it's still randomly rebooting. Any other ideas?
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    Are you positive you got all the launch items? Some of them are hard to track down if you are not familiar with those folders. Try running another Etrecheck report to make sure.

    If it is cured in another account, that is pretty much proof positive it is a user login or launch item causing the issue.
     
  6. DeniK thread starter macrumors newbie

    Joined:
    Sep 29, 2016
    #6
    Yes - all the launch items are gone - ran Etrecheck to make sure. I created a test account, and so far no reboots....but when I closed the cover, it completely locked up. Took about 20 secs of holding down the power button before it booted up. Still seeing some of the same things on the activity monitor on the test account (high kernel_task & windowserver usage), and over 700 errors & faults on the console in an hour and a half.

    Any other ideas I could try? At this point, I'm thinking a clean install is about my only option...
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    Okay... so now it is locking up even from the test account?

    Try this then... hold the shift key when booting to start in safe mode and see if that fixes it. If it does, then it is one of the other (non-user) launch items on the Etrecheck list.
     
  8. DeniK thread starter macrumors newbie

    Joined:
    Sep 29, 2016
    #8
    Ugh. Put it into safe mode last night, and it ran fine for about 2 hrs before I closed the lid to put it to sleep. About an hour later, I heard the startup sound, and then a minute or two later, heard it again....so I just shut it down for the night.

    Just pulled the Adobe launch daemons, and will give it a few hours to see what happens...

    Thanks for all your help Weaselboy!
     
  9. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #9
    That safe mode stops all third party items like the Adobe stuff from running. So if you are still having this issue in safe mode, it is more likely some hardware issue and I would take it in to Apple. Sorry.
     
  10. DeniK thread starter macrumors newbie

    Joined:
    Sep 29, 2016
    #10
    I'll get a time scheduled w/the genius bar then. Thanks again for your help!
     
  11. DeniK thread starter macrumors newbie

    Joined:
    Sep 29, 2016
    #11
    Quick update - took it to the Genius Bar. The tech tried to run Apple's diagnostics (MRI) on it - took almost 5 mins to get it started, and then errored out after 15 minutes. SD card reader was the only issue it found before it locked up. Ended up having it sent in for repair, and they replaced the logic board & battery. Didn't say what the actual issue was on the work order, just the parts that got replaced...
     

Share This Page