rare problem with 2.1 firmware on iphone 3g

Discussion in 'Jailbreaks and iOS Hacks' started by alejandrodj, Sep 15, 2008.

  1. alejandrodj macrumors newbie

    Joined:
    Sep 15, 2008
    #1
    hey guys. i want some direction or help maybe i can find the solution here. i bought an iphone 3g maybe 2 weeks ago now. it had the version 2.0.1 if am not wrong.
    after a couple of days of having it. i decided to try the pwn tool and i made a customized ispw file of the 2.0.2 with cydia and installer and i think i updated to the official 2.0.2 before doing the pwn tool operation.
    so after i put the iphone on dfu mode. i proceeded to restore to the customized firmware. and everything went smoothly. i had cydia. installer. and the phone worked just fine. which has a legit contract with at&t.
    i spent a couple of days happy with my customized iphone 3g until i saw on itunes that there was a new itunes 8 and also a new firmware 2.1
    and i also read that if i upgraded to 2.1 my phone was going to be become unjailbroken.
    to make the long story short. i plugged it in itunes because i wanted to sync with some videos from the podcast section. and the phone just froze. and it turned off itself. when i turned it back on. the "connect to itunes" screen showed up and the phone appeared to be unactivated.
    so i read a lot and found out that the new quickpwn and the pwn tool were able to support the 2.1 firmware so i upgraded.
    when the upgrade finished. the itunes gives me the message that the phone cant be activated because it cant gather the necesary information and to make sure i do not have a pin locked sim card and that is an activaded sim card. which it is.
    i try the quickpwn and it unlocks the phone but it does not show as if i have phone service. is like.. if it was an ipod touch. it does not show the bars or the at&t name. and i dont have internet. i do not know what to do. i tried to go back to 2.0.2 and it does not let me.
    one think i have to say is that when i upgraded to 2.1 i never upgraded to the official version first. i customized the 2.1 and from 2.0.2 i upgraded to the customized 2.1 . do you think that had something to do with the issues im having now? please i know i wrote a lot but if you managed to read all the way to this point please tell me what else i can do. i am thinking in going to apple but i am afraid they will see that i messed up with the software using pwn tool. i restored from itunes to the official 2.1 and i hope there is no trace of what i did.
    can somebody please tell me what else can i do to make the cellphone to recognize the carrier and the phone number and let me make calls and use the internet?
    I WAIT FOR YOUR ANSWERS. THANKS
     
  2. quikadanquik macrumors member

    Joined:
    Jul 23, 2008
    #2
    i had similar problems when moving to 2.1
    i simply continued to restore to stock 2.1 until i got it to work correctly then i restored to the custom 2.1 and everything works fine (most of the time)
     
  3. alejandrodj thread starter macrumors newbie

    Joined:
    Sep 15, 2008
    #3
    i will try that. let me ask you one more thing. around how many times did you restore until you got it to work? and also. you kept restoring to the original 2.1 right? you kept putting in DFU and then restoring using itunes 8? because if i try with 7.7 it wont recognize it. and if i try to restore in normal mode the itunes 8 says it cant recognize the iphone because it cant gather the necesary ifnormation so i must put it in DFU. and one last question. you kept restoring with the sim inside or without the sim?
    thanks a lot.:mad:
     

Share This Page