Rat 7 - r.a.t 7 - yosemite issues

Discussion in 'OS X Yosemite (10.10)' started by jamessezhi, Aug 26, 2014.

  1. jamessezhi macrumors newbie

    Joined:
    Oct 11, 2013
    #1
    I have a RAT 7 mouse by Cyborg and I'm experiencing issues using this mouse on OS X Yosemite Beta.

    1. When booting up at the log in page. If I move the mouse left, it points to the right. If I move the mouse right, it points to the right. It refuses to move left, only right.

    2. Once I enter my password and log in. I can move the mouse properly but if I hover the pointer over something it isn't detected. I have to click for the pointer to be detected. The Mad Catz application is not working properly. I therefore cannot configure my mouse properly.

    Any help would be much appreciated,

    James
     
  2. Bending Pixels macrumors 65816

    Joined:
    Jul 22, 2010
    #2
    It could be (and most likely is) that Cyborg hasn't provided compliant drivers to Apple yet for Yosemite. Use Feedback Assistant to let Apple know about this issue.
     
  3. jamessezhi thread starter macrumors newbie

    Joined:
    Oct 11, 2013
    #3
    VERY DISAPPOINTING - SEE THE FOLLOWING - CAN ANYONE PLEASE RECOMMEND A MOUSE THEY LIKE USING ON YOSEMITE ?

    15:53Mad Catz: Thank you for contacting U.S. Mad Catz! My name is Michelle. I will gladly help you in just a moment.
    15:54Mad Catz: We do not have any drivers for that software as it has not been released officially.
    15:54jamessezhi: Why is there no press release for this ?
    15:55Mad Catz: What?
    15:55Mad Catz: What do you mean?*
    15:55jamessezhi: I just updated my OS and before doing so I googled this info and ran through your website to make sure there were no raised issues using the RAT 7 on Yosemite.
    15:55Mad Catz: Apple doesn't inform anyone about the updates they make.
    15:56jamessezhi: Are you aware that the RAT 7 does not work of Yosemite ?
    15:56Mad Catz: As of right now all Apple only has a beta version that we know of and not a full version.
    15:57Mad Catz: A product can't be known to work with another device if it's not completed.
    15:57jamessezhi: Okok.
    15:57jamessezhi: Any advice please ?
    15:57jamessezhi: I need to use my RAT on Yosemite.
    15:57jamessezhi: Beta.
    15:58Mad Catz: It's not going to work.
    15:58Mad Catz: It's not an official release and its not finalized either.
    15:59jamessezhi: Is Cyborg going to release a temp driver at least ?
    15:59Mad Catz: No
    16:00Mad Catz: There will be more news when that software is complete and when we hear word from our development team. We don't make beta software for an incomplete software on an operating system.
    16:02jamessezhi: Approx how many people have raised this issue with Cyborg ?
    16:02Mad Catz: You are the only one.
    16:02jamessezhi: Seriously?!
    16:03Mad Catz: Yes, it's only a beta version meaning its not finalized.
    16:03jamessezhi: Alright. Thanks for the info.
    16:04Mad Catz: You're welcome. Have a great day.
     
  4. Maximus434 macrumors regular

    Joined:
    Jan 11, 2006
    #4
    I had these exact same issues with the RAT7 in Mavericks - it simply means the software is not installed. Go to the Cyborg website and download the Mac OS software (it must contain the drivers) because it behaves properly once the software is installed.
     
  5. jamessezhi thread starter macrumors newbie

    Joined:
    Oct 11, 2013
    #5
    GOOD NEWS - WORKS - PULLED FROM: http://forums.anandtech.com/showthread.php?t=2360002

    so, i uninstalled mad catz OS X driver app and installed USB overdrive, this gave me full control over all mouse buttons in a more mac like interface, plus acceleration control etc, only thing lost vs mad catz app is battery level and some dpi fine tuning

    other mac mouse drivers include SteerMouse and ControllerMate, either one should also work fine
     
  6. Polyphem54 macrumors newbie

    Joined:
    Oct 18, 2014
    #6
    Problem with R.A.T 9 on OS X Yosemite

    Hey guys;)
    I tried Steermouse and USBOverdrive but I still have the problem, that when I move the cursor over something it won't highlight as usual. It is really annoying, could someone help me please?
     
  7. Ribberman macrumors newbie

    Joined:
    Nov 4, 2014
    #7
    Hi there,
    Had the same issues but got it working. Not with USB-overdrive! When I had that installed my MAC did not recognize my mouse hovering over stuff.

    I just re-installed the RAT-software for mac 10.9 and it worked for me:
    http://madcatz.com/downloads/

    Maybe worth trying before trying usb-overdrive.

    Enjoy!
     
  8. MacLabTech macrumors newbie

    Joined:
    Apr 7, 2014
    Location:
    North Carolina
    #8
    MMO 7 Issues

    I'm having similar issues with my Mad Catz MMO7 on 10.10.1. None of my programable button in their software work, and that when I latch keys to certain buttons they never work. On my Windows 8 build the mouse and software work flawlessly. I chatted with them (after the full release of Mavericks) and basically got the same answer. I just don't understand why that haven't taken the time to write a driver for OS X.
     
  9. jtorres11 macrumors newbie

    Joined:
    Feb 12, 2015
    #9
    So this is what worked for me

    Ive been working w the rat 7 for almost a year now w no problems, I use it at work and I do Motion GFX for a living, the computer I used then was a top of the line iMac that worked w the current updated version of whatever os was at the time, but a couple weeks ago I got a macPro that came in w Yosemite, I know my mouse worked on Yosemite bc the iMac did and it worked just fine, but for some reason after installing my software the little icon on the menu bar did not appear and my profile will not load at all, even w the software window open and hitting the target looking icon to activate it. So i went to the IT guy at work(im not a computer guy myself, I use gfx software but the giblets of computers are beyond my understanding) his answer was there must be no support on this OS. His argument was that this worked fine in the iMac with the same up to date software, bc it had previously ran other os and the mad catz software was installed on previous versions and went along w the updates. So i tried uninstalling and installing and stuff and blogs and nothing worked until my work gave me 2 brand new displays to replace my simple monitors. I use 2 screens w the same space going all across the screen (not the one that has a menu bar per screen), so the moment I unplugged my second display I noticed that all the icons arranged and icons on the dock became default.. like safari, iphoto and face time and all the proprietary apple software was back on the dock, and my stuff like houdini or the adobe sweet elements went away... I decided to go back to the default os10.10 space stuff (displays have separate spaces) I uninstalled the madcatz software and installed it again and then it work, icon went to menu bar and the software runs like never happened, I restarted and then switch to my usual space configuration.. and all the modes work fine for the software I set them up too..
    So thats it, try going back to the original spaces configuration bc it seems that the software was being installed on a task bar that was not displayed to me when I had 2 screens.

    computer specs
     

    Attached Files:

Share This Page