Rattling Milanese Loop w/ S4 Gold SS

shadowyman

macrumors member
Original poster
Nov 12, 2013
52
0
Hello, I’ve just received my ss watch and gold milanese loop. I notice that the lower end connector of the band rattles once inserted into watch. The upper end doesn’t do this. This happens when you wiggle with the band. It’s almost like the opening of the lower end is bigger than the band connector piece. I have tried the same with my old s2 milanese loop and it doesn’t happen.

Can you confirm if your new milanese loop has the same problem with s4 watch? Should I have it replaced? The same happens with S2 and S4 gold milanese loop.
 

TheBearman

macrumors 6502
May 23, 2008
432
72
Cary, NC
I've heard a couple folks comment that the "new" loop was altered to allow the watch to lay flat for induction charging mats.
 

tromboneaholic

Suspended
Jun 9, 2004
3,706
3,024
Clearwater, FL
Hello, I’ve just received my ss watch and gold milanese loop. I notice that the lower end connector of the band rattles once inserted into watch. The upper end doesn’t do this. This happens when you wiggle with the band. It’s almost like the opening of the lower end is bigger than the band connector piece. I have tried the same with my old s2 milanese loop and it doesn’t happen.

Can you confirm if your new milanese loop has the same problem with s4 watch? Should I have it replaced? The same happens with S2 and S4 gold milanese loop.
try flipping it around so you put the top connector in the bottom and the bottom connector in the top. If the wiggle changes sides, it's the band. If not, it's the watch.
 

Xarthan

macrumors regular
Jul 11, 2008
156
66
Mine wiggles a bit on the bottom, but the top is solid. Does your metal thing come off the bottom thingy?
 

xqtr

macrumors member
Jun 2, 2017
36
29
I have an aluminum S4 and the bottom connector wiggles a bit with the band.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.