Razer 1.6 problems after Leopard install

Discussion in 'macOS' started by ikenstein, Oct 28, 2007.

  1. ikenstein macrumors member

    Joined:
    Jul 19, 2007
    Location:
    New York, NY
    #1
    After installing Leopard, my right mouse button registers as a left click and my scroll wheel does not work (for scrolling or as a button). I have the razer software installed, but it doesn't seem to be working. any thoughts?
     
  2. teekayx macrumors newbie

    Joined:
    Jun 22, 2007
    #2
    You know what? I had exactly the same problem. And I got really unnerved because the first time Leopard ran, the mouse worked just fine.
    Well fortunately I had a 10.4 install still on my backup HD, so I fired that up to check what the difference was. :)

    After running "ps aux" on the command line I found out, that there was this daemon running in Background:

    teekayx 205 0.0 -0.2 355324 3396 ?? S 7:58PM 0:00.11 /Library/Application Support/Razer/RazerPRODaemon.app/Contents/MacOS/RazerPRODaemon -psn_0_262145

    Well.. on Leopard it was not running, so I tried running it manually and voila, the mouse worked again as expected!

    Go to /Library/Application Support/Razer/ and double-click on RazerPRODaemon.app - it looks like nothing happens, but the daemon process is started, your mouse should work correctly now.

    Since I dont have a clue how one can get this program started on every system startup (for every user) I just put the app under my Start Objects in the userpane of control panel. This should fix your problem. (But if you restart your system and logon using a different user, your mouse wont work unless you start this program manually again)
    If anybody knows how to make the programm start at system startup, let me know.

    Hope this fixes your problem, I was already angry at being forced to ditch my Razer Mouse for the unbareable mighty mouse...
     
  3. ibookowner2 macrumors regular

    ibookowner2

    Joined:
    Mar 29, 2005
    #3
    my razer is now also not working. I have managed to get the scroll back but still no right click.
     
  4. ikenstein thread starter macrumors member

    Joined:
    Jul 19, 2007
    Location:
    New York, NY
    #4
    thanks. i'm not tech savvy enough to understand any of that, but i did install steermouse and after playing with the settings a little, i now have all my functionality back, plus some. i'm a happy camper
     
  5. adamswick macrumors newbie

    Joined:
    Jan 29, 2008
    #5
    Not working with my Razer Diamondback and Leopard 10.5.1

    OS: Leopard 10.5.1
    Driver: Razer Pro|Click V1.6, Mac OS X 10.5 Leopard Driver v1.6.7​

    Buttons 5 and 7 (right-hand side of the mouse) do not work when I log in.

    If I switch to another user account and then switch back to my account, all mouse buttons work. The mouse now works as it should.

    Does anyone have a solution for this?
     
  6. hodgjy macrumors 6502

    Joined:
    Apr 15, 2005
    #6
    I've been running driver 1.6.6 with no problems. I'll install 1.6.7 and see what happens.....
     
  7. hodgjy macrumors 6502

    Joined:
    Apr 15, 2005
    #7
    Version 1.6.7 seems to work just the same for me as 1.6.6. The only thing I can suggest is make sure you're using the Leopard version for the drivers if you're on Leopard (OP) and the Tiger version if you're on Tiger (others).
     
  8. adamswick macrumors newbie

    Joined:
    Jan 29, 2008
    #8
    Got it working

    Thanks for the tip -- I also noticed the separate installs, but you made me think of something.

    I did a case-insensitive search for "Razer" and found that I still had remnants from the last 3 installs of the mouse drivers. I could see files for version 1.65, 1.66 and 1.67. I know for a fact that 1.65 was installed when the system was using Tiger.

    What this means is that the Razer install does not cleanup previous installations. After I removed all of the "Razer" references, reinstalled Razer Pro|Click driver version 1.67f4 for Leopard and restarted, everything works as it should.

    I like my Razer mouse, but this is sloppy application development.
     

Share This Page